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Chapter 1

Introduction

1.1 About this Document

This is the LyX Reference Manual.

If you’ve looked at some of the other documentation, you might be expecting
this section to be identical to all of the other opening sections in the other
documentation files. The Reference Manual isn’t like the other documents, and
requires a somewhat different approach.

First, this file is big. It contains ...well, everything. Or, it will, at some
point. At the moment, though, it’s still somewhat incomplete.

Second, to help you get started with this manual, we recommend that you
have a look at the example entries. We’d also recommend not printing out the
entire manual, but only those sections you happen to need. [This document is
still a moving target, after all.]

Third, the entries in this manual follow a somewhat-modified version of the
format described in the Introduction manual. Most of these modifications are
additions to what’s been specified in the Style Sheet. So, if you intend to add
an entry, make sure you read DocStyle.1lyx thoroughly! [You’ll find it in the
distribution in the development subdirectory.]

NOTE: this document is, alas, very out of date. It is wrong in many places,
and omits lots of information about newer versions of LyX.

1.2 Organization

Each chapter is grouped around a central theme or topic. Chapter 2 describes
the user interface. Included are the tool bar, the various popups and which
menu items and keys they are bound to. Chapter 3 lists all of the bindable
functions. You’ll need this information if you want to alter the key bindings
or create your own tool bar. Lastly, chapter 4 is the Dreaded Miscellaneous!
Basically, anything we couldn’t figure out where to put ended up here.

9



10 CHAPTER 1. INTRODUCTION

The entries themselves are the subsections of each chapter. They are in
alphabetical order for ease of access. The sections of each chapter have single
purpose: to split up the chapter into more manageable chunks. They simply
group the entries by letter, so, for example, there will be a section labelled
“A-C,” another called “S,” and so on.

1.3 A Sample Entry

This is a sample entry to the Reference Manual. It should help readers figure
out how to use this manual, and show developers how to create entries.

The first thing to notice it the entry name. It’s not in any special font. Now,
according to the Style Sheet, function names should be in Typewriter font and
the names of popups in Sans Serif. If you check the chapters containing entries
for the functions and popups, you’ll see that those entries do indeed use this font
convention. . .in the text itself. The names of the entries — i. e. the subsection
title — is in the default font. Leave the entry titles in the default font.

1.3.1 Example #1: Entries
Default Bindings:

Menu - Where in the menus you can find this thing. If the menu
item just brings up a dialog box, put its name in as a
Description list. Also put in where on the panel the item
in bound. Put the names of menus, popup buttons, etc.
in Sans Serif to make it stand out from any other text.
Underline the accelerator key, if any.! Example:

MenuName >SubMenuName »>IltemName
Ding a Ling Panel: ThisButton

Toolbar - Should describe the location on the bar and what the icon
looks like. Keep it brief. Example:

Fourth button from the left.

Hand with six fingers.

Keyboard - There will be either one or two paragraphs here. They
should just contain a key sequence, and the name of the
binding file. Put the name of the binding file in Typewriter
font, and the key sequence in Sans Serif to make it stand
out. If no binding file name is present, then that binding
is standard in all of the binding files. Example:

C-M-p in bindfile.bind.
M-9

n other words, this is just as described in the Style Sheet.
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Purpose: The purpose of this entry is to describe these entries.

Within an entry, the different parts are labelled “Default Bindings:“, “Pur-
pose”, “Usage”, “Examples”, and “See Also”. These are each paragraph headings.
The “Menu-“, “Toolbar”, and “Keyboard” parts of “Default Bindings:* are sub-
paragraph headings. None of these should be numbered.

In a real entry, this will tell you about the item and what it’s for.

Usage: This entry will tell you how to use this item.

There won’t always be one of these. In fact, any of the”’standard” sections of
an entry may be missing, especially if it’s empty. For example, there are only
15 or so toolbar buttons, so most things won’t have a default toolbar binding.
Or, the author of an entry may prefer to put some of the “Usage” stuff under
“Purpose” or “Examples”.

Examples: This is an example example for an example entry.

Are you confused? Good. You came to the right place!

Unfortunately, this example entry has been kind of abstract. So, we’ll give
you a few more example entries.

See Also: Example #2; Example #3.
[Notice that this isn’t in any special font. |

1.3.2 Example #2: Bogosify
Default Bindings:

Menu - Bogus>MuHaHa
Toolbar - First button from the left.
Bogus ball.

Keyboard - C-F50 in bogus.bind.
C-W-Help in PCbogus.bind.

Purpose: This item puts extra bogosity in your documents by activating the
bogofilter in BoGoTEX. Everyone needs a little bogosity in their writings. Oth-
erwise, you risk boring your readers into a deep sleep. In fact, some science
professors, scoffing at the usefulness of the BoGoTEX extensions, have written
and even published articles in reputable journals that have been known to put
readers into a coma! Don’t believe me? Try reading just about any scientific

paper!

Usage: Just select the text to bogosify with the mouse, then use the keyboard
bindings, toolbar button, or menu item for this function.

Examples: Why, this entire entry is an example! It’s totally bogus!
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See Also: BogoMIPS

1.3.3 Example #3: Decat
Default Bindings:

Menu - Cuddly > Eeline to bring up the Meow dialog box.
Meow Panel: Decat button.

Toolbar - Button smack dab in the middle of everything.
Kitty-cat.

Keyboard - W-c W-a W-t in fuzzy.bind.

Purpose: The decat function fixes “additions” made by overly-helpful paws.

We all know how much cats love computers, especially the laps that sit in
front of them. However, a cat, being feline, must add its opinions to whatever
you're typing. Or, your cat may simply decide to help you finish your work
so you can get to more important matters, such as brushing and petting. The
decat function is designed for just such moments.

Usage: Select the text to decat while holding down all five mouse buttouns,
then use the keyboard bindings, toolbar button, or menu item for this function.

Examples: A particular black and white cat once added the following;:
sfd4rcxy45bb q43 tfd t43revex
...to a document. Run through decat, it became:
Hey, bozo! Pay attention to me!
Another frisky kitty named Horatio added:
’;; msdam m-009243m laasd;mlk
to some text. Decat changed it to:
Can I beat up another dog?

[And if you believe that, I have a bridge in Brooklyn for sale.. .|

See Also: ASPCA; PETA; ECC; Any cat owner.
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1.3.4 Template
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: FExamples.

See Also: Other entries or documents. Separate many references by either a

[19%2]

;7 or place in multiple paragraphs.
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Chapter 2

User Interface: The Popups

Ed. Note: The chapter with a blow-by-blow description of what each popup does,
which menu its bound to, and so on. Rather incomplete at the moment.-jw

2.1 A-E

2.1.1 Character Layout
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a
“” or place in multiple paragraphs.

2.1.2 Decoration

Default Bindings:

Menu - Main > ltem

15
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Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a
“” or place in multiple paragraphs.

2.1.3 Delimiter
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

€@

;7 or place in multiple paragraphs.

2.1.4 Document Layout
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.
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Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

1%}

;7 or place in multiple paragraphs.

2.2 F-H

2.2.1 Figure
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: FExamples.

See Also: Other entries or documents. Separate many references by either a

1%}

;7 or place in multiple paragraphs.

2.2.2 File browser

Default Bindings: There are actually several, since many different operations
in LiyX require a filename. Some of the more common functions which use
a file browser have the following bindings:

Menu - File> New
File> New from template...
Filer>Open
File>Save As

Toolbar - Button # from the left (or right).

Brief description of button icon.
Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.
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Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

@

;7 or place in multiple paragraphs.

2.2.3 Find & Replace
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

1%

;7 or place in multiple paragraphs.

23 IJ
2.3.1 Include
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.

Usage: Description.
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Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

1%}

;7 or place in multiple paragraphs.

2.3.2 Insert Figure
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

[19%2]

;7 or place in multiple paragraphs.

2.3.3 Insert Reference

Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

€@

;” or place in multiple paragraphs.
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2.3.4 Insert Table
Default Bindings:

Menu - Main > Item

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

1%l

;7 or place in multiple paragraphs.

2.3.5 Itemize Bullet Selection
Default Bindings:

Menu - Layout> Document to bring up the Document Layout
popup.
Document Layout: Bullet Shapes

Keyboard - M-li

Purpose: Allows you to change the bullets that appear at the various levels
of an Itemize layout on a per document basis.

Usage: The popup provides you with a table of bullet shapes. A column of
buttons on the left of the table provides access to the six different panels of bullet
shapes. The row of buttons across the top is used to select which bullet depth
you are changing. A text entry under the table shows the currently selected
bullet shape’s IWTEX equivalent and this can be edited if desired.

Select which bullet depth you want to change then select the bullet shape
and size. Ok and Apply will update the document. Changes will not be visible
in LyX, but are visible when viewing the document using xdvi or ghostview.

See Also: buffer-itemize-bullets-select;
Itemize Bullet Selection in Eztended Features;
ItemizeBullets.lyx in the examples directory.
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2.3.6 Key Mappings
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: FExamples.

See Also: Other entries or documents. Separate many references by either a

1%}

;7 or place in multiple paragraphs.

24 K-O

2.4.1 FETEX Log
Default Bindings:

Menu - Edit> View IATEX Log
Keyboard - M-ew

Purpose: Displays the log file produced by BTEX.

Usage: Scroll through the log file using either the cursor keys or the scrollbars.
The Update button will refresh the popup with the log file contents.

See Also: latex-view-log;

2.4.2 FKETEX Options
Default Bindings:

Menu - Main > Item

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.
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Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

@

;7 or place in multiple paragraphs.

2.4.3 Math Panel
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S5-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

1%

;7 or place in multiple paragraphs.
2.4.4 Matrix

Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S5-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.

Examples: Examples.
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See Also: Other entries or documents. Separate many references by either a

€@

;7 or place in multiple paragraphs.

2.5 P-Q

2.5.1 Paper Layout
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

1%}

;7 or place in multiple paragraphs.

2.5.2 Paragraph Layout
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

.

;” or place in multiple paragraphs.
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2.5.3 Print

Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

€@,

;7 or place in multiple paragraphs.

2.5.4 Quotes

Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).

Brief description of button icon.
Keyboard - C-S-M-W-key in filel.bind.
C-S5-M-W-key in file2.bind.
Purpose: Description.
Usage: Description.

Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

€@

;7 or place in multiple paragraphs.
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26 S

2.6.1 Screen Options
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

1%}

;7 or place in multiple paragraphs.

2.6.2 Send Document to Command

Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).

Brief description of button icon.
Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.
Purpose: Description.
Usage: Description.

Examples: FExamples.

See Also: Other entries or documents. Separate many references by either a

€@

;” or place in multiple paragraphs.
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2.6.3 Spacing

Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

€@,

;7 or place in multiple paragraphs.

2.6.4 Spellchecker

Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).

Brief description of button icon.
Keyboard - C-S-M-W-key in filel.bind.
C-S5-M-W-key in file2.bind.
Purpose: Description.
Usage: Description.

Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

€@

;7 or place in multiple paragraphs.
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2.6.5 Spellchecker Options
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

€@

;” or place in multiple paragraphs.

2.7 T-Z

2.7.1 Table Layout
Default Bindings:

Menu - Main > ltem

Toolbar - Button # from the left (or right).
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.
Purpose: Description.
Usage: Description.

Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

€@

;” or place in multiple paragraphs.
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2.7.2 Table of Contents
Default Bindings:

Menu - Edit>Table of Contents
Keyboard - M-et

Purpose: Displays the Table of Contents of the current document. Also allows
rapid browsing and movement between sections.

Usage: You can move about the table of contents using either the scrollbar or
your cursor keys. Only two buttons are provided. A Close button to close the
popup and an Update button to rebuild the table of contents. If you click on an
entry with your mouse or move the selector using the cursor keys the document
is moved so that that section is visible on screen. This allows rapid and simple
navigation through your documents.

Examples: Try it now.

See Also: toc-insert; toc-view; Table of Contents in User Guide



Chapter 3

Bindable Functions

We have some quick, last minute notes for you about this chapter.

If a particular piece of an entry is missing, it’s equivalent to saying, “There
is none.” For example, if, under “Default Bindings” there was no “Menu”
item, it means there is no menu binding. Likewise, the guy who wrote the entry
may have decided that the function’s purpose is self-explanatory. So, there’d be
no “Purpose” section in the entry.

Hopefully, all of that is clear.

If you haven’t noticed already, this is a huge chapter. Your best bet for get-
ting around in it is to open up the Table of Contents browser. Select Table of Con-
tents... from the Edit menu.

Lastly, some credits:

ALEJANDRO AGUILAR-SIERRA wrote the math entries.

RicH FIELDS wrote most of the entries in here.

JOHN WEIss edited this chapter.

3.1 A

3.1.1 accent-acute

Default Bindings: None.

Purpose: To produce accented characters from the ISO-Latin-1 character set.
All of the commands of the form “accent-xxxxxx,” are of the same type.

Rather than repeat the same entry 17 times, we’ll explain how all of the “accent-*"
commands work.

Usage: All of the “accent-** commands work like a “Compose” key. They
add a particular accent to the next character typed. There are two ways to use
these commands:

1. Direct Execution:

29
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(a) Use the “command-execute” key to enter the desired “accent-*”
command in the minibuffer.
[See the entry for “command-execute” if you don’t know how to ex-
ecute LyX commands directly.]

(b) Next, type the letter you wish to accent.
2. Dead Keys

(a) Bind the desired “accent-*" command to a keyboard key. Typically,
you bind the command to the key that looks like the accent.

For example, you’d bind “accent-acute” to the apostrophe key (the
’) and “accent-circumflex” to the “~” key (Shift-6 on a US key-
board).

[See the manual Customization.lyx for information about binding
keys.|!

(b) Restart LyX if it’s already running, so that the new bindings can
take effect.

(c) Type the dead-key, followed by the letter you wish to accent.

Using our earlier example, if you type “~” followed by the letter “e”,
you’ll produce the character “&”.

To produce the accent by itself, hit the Space key instead of a character.

Examples: This command produces the following accent;:

Valid letters with an acute accent:
a6ionyAEIOUYsz2SZil¢énRLCN

See Also: command-execute;

the key binding section in Customization.lyx ;

accent-breve; accent-caron; accent-cedilla; accent-circle; accent-circumflex;
accent-dot; accent-grave; accent-hungarian-umlaut; accent-macron; accent-special-
caron; accent-tie; accent-tilde; accent-umlaut; accent-underbar; accent-underdot.

3.1.2 accent-breve

Default Bindings: None.

Examples: This command produces the following accent:

Valid lvettverg, with a breve accent:
AagiAGU

LEditor’s Note: I may change this and put an entry to the bind command in this manual.
-jw
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See Also: accent-acute.

3.1.3 accent-caron

Default Bindings: None.

Examples: This command produces the following accent:

Vahd letters with a caron accent:

C' dTafrtDLNRTGE

See Also: accent-acute.

3.1.4 accent-cedilla

Default Bindings: None.

Examples: This command produces the following accent:

)Valid letters with a cedilla accent:

¢CgklnrstGKLNRST

See Also: accent-acute.

3.1.5 accent-circle

Default Bindings: None.

Examples: This command produces the following accent:

Valid letters with a circle accent:
aaAU

See Also: accent-acute.

3.1.6 accent-circumflex

Default Bindings: None.

Examples: This command produces the following accent:

~

Valid letters with a c1rcumﬂe accent:
aeioaAEIO GHIJIS

G)
O)

See Also: accent-acute.

31
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3.1.7 accent-dot
Default Bindings: None.

Examples: This command produces the following accent:

Vali.d letters yvi‘gh a dot accent:
¢iElcgzCGZ

See Also: accent-acute.

3.1.8 accent-grave

Default Bindings: None.

Examples: This command produces the following accent:

Valid letters with a grave accent:
Aa¢10uAEIOU

See Also: accent-acute.

3.1.9 accent-hungarian-umlaut

Default Bindings: None.

Examples: This command produces the following accent;:

Valid letters with a hungarian umlaut accent:
640U

See Also: accent-acute.

3.1.10 accent-macron

Default Bindings: None.

Examples: This command produces the following accent:

Valid letters with a macron accent:
ael1ouAEIOU

(@]l

See Also: accent-acute.
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3.1.11 accent-special-caron

Default Bindings: None.

Examples: WARNING! THIS ACCENT COMMAND CURRENTLY CRASHES
LyX! DO NOT USE!
This command produces the following accent:

Some letters with a special caron accent:

See Also: accent-acute.

3.1.12 accent-tie
Default Bindings: None.

Examples: This command produces the following accent:

Valid letters with a tie accent: None. Just the accent itself.

See Also: accent-acute.

3.1.13 accent-tilde
Default Bindings: None.

Examples: This command produces the following accent:

=

Valid letters~w~it a tilde accent:
nNaioaAIOU

(@}l

See Also: accent-acute.

3.1.14 accent-umlaut

Default Bindings: None.

Examples: This command produces the following accent:

Some letters with an umlaut accent:
aeiouyAEIOU

See Also: accent-acute.



34 CHAPTER 3. BINDABLE FUNCTIONS

3.1.15 accent-underbar

Default Bindings: None.

Examples: This command produces the following accent:

Some letters with an underbar accent: None. Just the accent itself.

See Also: accent-acute.

3.1.16 accent-underdot
Default Bindings: None.

Examples: This command produces the following accent:

Valid letters with an underdot accent: None. Just the accent itself.

See Also: accent-acute.

3.2 B

3.2.1 backward-select
Default Bindings:

Keyboard - S-Left

Purpose: Highlights a single character to the left of the current cursor loca-
tion. If the cursor is at the left screen margin the cursor moves to the end of
the previous line, and the whitespace in-between is selected. The selected text
will be in reverse-video.

See Also: char-backward;

forward-select; up-select; down-select; word-forward-select; word-backward-
select; line-begin-select; line-end-select; screen-up-select; screen-down-select; buffer-
begin-select; buffer-end-select.

3.2.2 break-line
Default Bindings:

Menu - Insert > Special Character > Linebreak
Keyboard - C-Return
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Purpose: To forcibly split the current line without ending the current para-
graph.

Usage: This command has several purposes, depending on context. Its pri-
mary function is to manually end a line without ending the paragraph. This
should only be done when you need some fine-tuning.

In math-mode, the break-line command automagically turns a one-line
equation into a multiline expression, inserting the new equation line as well as
all alignment delimiters.

See Also: break-paragraph; break-paragraph-keep-layout.

3.2.3 break-paragraph
Default Bindings:

Keyboard - Return
Purpose: To terminate the current paragraph.

Usage: This command does slightly different things, depending on context.
Typically, it ends the current paragraph, breaks the current line, and starts a
new paragraph in the Standard paragraph environment on the next line. It also
typically removes all environment nesting.

If you are in the middle of a paragraph, break-paragraph splits it in two.
If the paragraph is a list item, it creates a new list item in the process.

If you are at the end of a paragraph, break-paragraph starts the new para-
graph after the current one. If you are at the beginning of a paragraph, the new
paragraph starts before the current one.

break-paragraph may start the new paragraph in an environment other
than Standard, but the behavior is not consistent. For example, if you move to
the middle of an Itemize list, to the end of one of the items or the beginning of
the next item, break-paragraph will not change the paragraph environment.
It will still mess up the environment nesting, however.

Examples: None. Your best bet is to just play with hitting return until you
build an intuition for how this works.

See Also: break-paragraph-keep-layout; break-line;
depth-decrement; depth-increment.

3.2.4 break-paragraph-keep-layout
Default Bindings:

Keyboard - M-Return
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Purpose: To terminate the current paragraph without changing the para-
graph environment or nesting depth.

Usage: Its usage is very much the same as break-paragraph, with one im-
portant difference. The new paragraph always has the same environment and
nesting depth as the old one.

See Also: break-paragraph; break-line;
depth-decrement; depth-increment.

3.2.5 buffer-auto-save
Default Bindings:

Keyboard - C-x a or C-x C-a in emacs.bind only.
Purpose: Forces an autosave on the current document.

Usage: Backward compatibility. This function used to be the only way to
undo any editing. With the advent of a true undo/redo function in LyX, forcibly
autosaving a document doesn’t have much use. (The undo-mechanism has been
limited to 100 steps in the beta-version.)

See Also: buffer-load-auto-save
3.2.6 buffer-begin
Default Bindings:

Keyboard - C-Home in cua.bind.

Home in emacs.bind.
Purpose: Moves the cursor location to the top of the current buffer.

See Also: char-forward; char-backward; word-forward; word-backward; line-
begin; line-end; tab-forward; up; down; screen-up; screen-down; buffer-end.

3.2.7 Dbuffer-begin-select
Default Bindings:

Keyboard - S-C-Home

Purpose: Highlights text from the current cursor location to the top of the
current buffer. The selected text is shown in reverse-video.
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See Also: buffer-begin;

backward-select; forward-select; up-select; down-select; word-forward-select;
word-backward-select; line-begin-select; line-end-select; screen-up-select; screen-
down-select; buffer-end-select.

3.2.8 buffer-chktex
Default Bindings:

Menu - Edit> Check TEX
Keyboard - M-e h (standard).

Purpose: Checks document for typographical errors.

Usage: This function runs ChkTeX on the document and inserts error boxes
with the results. It is used to find common typographical errors.

See Also: error-next; description in FExtended Features.

3.2.9 Dbuffer-close
Default Bindings:

Menu - File> Close
Keyboard - M-f ¢ (standard).

C-w in cua.bind.
C-x k or C-x C-k in emacs.bind.

Purpose: Closes the current buffer. If changes have been made since it was
first opened, or since the last buffer-save or buffer-save-as command, you
will be asked if you want to save the buffer to its file before closing the buffer.

See Also: buffer-open.

3.2.10 buffer-end
Default Bindings:

Keyboard - C-End in cua.bind.
End in emacs.bind

Purpose: Moves both the screen display and the current cursor location to
the end of the current buffer.
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See Also: char-forward; char-backward; word-forward; word-backward; line-
begin; line-end; tab-forward; up; down; screen-up; screen-down; buffer-begin.

3.2.11 buffer-end-select

Default Bindings:

Keyboard - S-C-End

Purpose: Selects text from the current cursor location to the bottom of the
current buffer. The selected text is shown in reverse-video.

See Also: buffer-end-select;

backward-select; forward-select; up-select; down-select; word-forward-select;
word-backward-select; line-begin-select; line-end-select; screen-up-select; screen-
down-select; buffer-begin-select.

3.2.12 buffer-itemize-bullets-select
Default Bindings:
Menu - Layout>Document to bring up the Document Layout
popup.
Document Layout: Bullet Shapes

Keyboard - M-1d M-b
M-11i

Purpose: Opens the document’s Itemize Bullet Selection popup which
allows you to change the bullets that appear at the various levels of an Itemize
layout.

See Also: Itemize Bullet Selection;
Itemize Bullet Selection in Extended Features;

3.2.13 Dbuffer-load-auto-save

Default Bindings: None

Purpose: Loads the autosave file.
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Usage: To invoke this function, you must use the command-execute key to
enter buffer-load-autosave in the minibuffer.

Invoking this command once loads the autosave file (which has the suffix
“.bak”) in place of the current document. Invoking it two times in a row loads
the autosave backup file (which has the “.bak™ suffix) in place of the current
document.

You cannot change the time interval between autosaves on the fly. The inter-
val, in seconds, is set in the main lyxrc file or in the user’s local ${HOME}/.1yx/lyxrc.

See Also: command-execute;
buffer-auto-save.

3.2.14 buffer-new
Default Bindings:

Menu - File> New
Keyboard - M-f n (standard).

C-n in cua.bind.

C-x d or C-x C-d in emacs.bind.
Purpose: Opens a new buffer for a new LyX document.

Usage: This function first opens a File Browser window. You must now specify
a new filename for the new document. You can use the File Browser to choose
the directory for the new file, but the file name itself must be unique. The file
cannot already exist.

See Also: File Browser;
LyX Template Files;
Editor’s Note: These first two will be added at a later date. - jw
buffer-new-template; buffer-open; buffer-close; buffer-write; buffer-write-as.

3.2.15 buffer-new-template
Default Bindings:

Menu - File> New from template

Keyboard - M-ft (standard).
C-N in cua.bind.

Purpose: Opens a new buffer for a new IyX document with a template doc-
ument.
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Usage: This function first opens a File Browser window. You must now specify
a new filename for the new document. You can use the File Browser to choose
the directory for the new file, but the file name itself must be unique. The file
cannot already exist.

After you enter the filename and choose OK, the File Browser window opens
again. This time, it has the title “Choose Template.” If you wish to use a
ILyX template file for this new document, use the File Browser to choose one.
Otherwise, hit the Cancel button.

See Also: File Browser;
LyX Template Files;
Editor’s Note: These first two will be added at a later date. - jw
buffer-new; buffer-open; buffer-close; buffer-write; buffer-write-as.

3.2.16 buffer-open
Default Bindings:

Menu - Filer Open
Toolbar - First button from the left.

File folder with an arrow.

Keyboard - M-f o (standard).
C-o0 in cua.bind.

C-x f or C-x C-f in emacs.bind.
Purpose: Opens an existing file and places it in a new buffer.

Usage: This function opens a File Browser window with the title “Document
to Open.” Choose the file to open and hit OK.

See Also: File Browser; [Editor’s Note: To be added. - jw |
buffer-open; buffer-close; buffer-write; buffer-write-as.

3.2.17 buffer-previous
Default Bindings:

Keyboard - M-d p (standard).

C-x b or C-x C-b in emacs.bind.

Purpose: Changes from the current document to another open and previously
viewed document.
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Usage: Self-explanatory.

If only one document is open, buffer-previous has no effect.

If more than two documents are open, buffer-previous switches to whichever
document you were last working on.

You can also switch between open documents using the Documents menu.

Using buffer-previous several times in a row switches back and forth be-
tween two documents. This is useful for cutting and pasting between two dif-
ferent documents.

See Also: Documents Menu. [Ed. Note - to be added. -jw]

3.2.18 Dbuffer-print
Default Bindings:

Menu - Filer Print
Toolbar - Button #3 from the left.
A stylized printer.

Keyboard - M-f p (standard).
C-p in cua.bind.

Purpose: Prints the current document.

Usage: This function opens the Print panel, which allows print control via
buttons and typed inputs; a buffer can be printed either to a file or to a spooled
print device. When printing to a printer, the printer name you specify in the
Printer box must be configured for dvips.? Most systems have “ps” as their
default PostScript@®) printer, for which dvips comes preconfigured.

See Also: The section on dvips in UserGuide.lyx;
Print panel; [Ed. Note - To be added. - jw.]
buffer-view; buffer-view-ps.

3.2.19 Dbuffer-typeset
Default Bindings:

Menu - File>Update dvi

Keyboard - M-f u (standard).
C-D in cua.bind.
Cxr, Cxt, Cx C-r, or C-x C-t in emacs.bind.

Purpose: Updates the dvi file for the current buffer (runs BTEX).

2This is explained in greater detail in UserGuide.lyx.
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Usage: A ITEX scratch file is created, based on the contents of the current
buffer, and the file is processed with IATEX. ITEX messages are posted to the
screen of the parent window, and approximate ITEX error locations are marked
within the current buffer with an error box; the text of the actual IXTEX error
can be displayed by clicking on the error-box.

See Also: error-next; buffer-typeset-ps.

3.2.20 buffer-typeset-ps
Default Bindings:

Menu - File> Update PostScript

Keyboard - M-f e (standard).
C-T in cua.bind.

Purpose: Updates the PostScript@®) file for the current buffer (runs BTEX
and dvips).

Usage: A ITEX scratch file is created, based on the contents of the current
buffer, and the file is processed with BTEX. Then, dvips is run to produce a
PostScript@®) version scratch file. ITEX messages are posted to the screen of
the parent window, and approximate INTEX error locations are marked within
the current buffer with an error box; the text of the actual IXTEX error can be
displayed by clicking on the error-box.

See Also: error-next; buffer-typeset.

3.2.21 Dbuffer-view
Default Bindings:

Menu - File> View (xdvi)
Keyboard - M-f d (standard).
C-d in cua.bind.

C-x p or C-x C-p in emacs.bind.
Purpose: Views the current buffer with the xdvi program.

Usage: A KTEX scratch file is created and processed, and a xdvi process
window is then automatically created with which you can view the resulting
dvi file. If any of these programs are not installed on your system, the process
stops at that point and control is returned to LyX.
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See Also: buffer-print; buffer-view-ps.

3.2.22 buffer-view-ps
Default Bindings:

Menu - File> View (ghostview)

Keyboard - M-f g (standard).
C-t in cua.bind.
C-x g or C-x C-g in emacs.bind.

Purpose: Views the current buffer with the ghostview program.

Usage: A IXTEX scratch file is created and processed, and dvips is run on the
resulting dvi file to create a scratch PostScript®) file. A ghostview process
window is then automatically created in which you can view your work essen-
tially in the same form as if it were printed. If any of these programs are not
installed on your system, the process stops at that point and control is returned
to LyX.

See Also: buffer-print; buffer-view.

3.2.23 buffer-write
Default Bindings:

Menu - File>Save

Keyboard - M-f s (standard).

C-sin cua.bind.
C-x s or C-x C-x in emacs.bind.

Purpose: Writes (saves) the current document to the original filename.

See Also: buffer-write-as.

3.2.24 buffer-write-as
Default Bindings:

Menu - Filer>Save As
Keyboard - M-f a (standard).
C-S in cua.bind.

C-x w or C-x C-w in emacs.bind.
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Purpose: Saves the current buffer to a different filename than that of the file
originally opened.

Usage: This function opens an browser window that allows you to specify a
new filename for the document.

See Also: buffer-write.

3.3 C-E

3.3.1 cancel

Default Bindings:

Keyboard - Escape in cua.bind.

C-g in emacs.bind.

Purpose: General cancel. Cancels the selection of a meta-key selection, a
drop-down menu, or a pop-up window. Cancels entry of commands in the
minibuffer. Also leaves math-mode.

Usage: Cancel is the primary method of leaving math mode. Also, if a meta-
key selection has been started, (for instance, M-c), pressing the cancel key will
abort the selection. Similarly, if a find-replace window is open, placing the
cursor in the window and executing the cancel function will close the window,
or if a drop-down menu has been selected, cancel will close the menu. Lastly,
if you are entering a command in the minibuffer, cancel will abort entry and
leave the minibuffer.

See Also: command-execute; find-replace; math-mode.

3.3.2 char-backward
Default Bindings:

Keyboard - Left (standard).

C-b in emacs.bind.

Purpose: Moves the cursor to the left by one character. At the beginning of
the line the cursor will move to the end of the previous line.

See Also: char-forward; word-forward; word-backward; line-begin; line-end;
tab-forward; up; down; paragraph-up; paragraph-down; screen-up; screen-down;
buffer-begin; buffer-end.



3.3. C-E 45

3.3.3 char-forward

Default Bindings:

Keyboard - Right (standard).

C-f in emacs.bind.

Purpose: Moves the cursor to the right by one character. At the end of the
line the cursor will move to the beginning of the next line.

See Also: char-backward; word-forward; word-backward; line-begin; line-end;
tab-forward; up; down; paragraph-up; paragraph-down; screen-up; screen-down;
buffer-begin; buffer-end.

3.3.4 command-execute

Default Bindings:

Keyboard - M-x in cua.bind and emacs.bind.

Purpose: Executes a LyX function.

Usage: After you invoke command-execute, a cursor will appear in the minibuffer.
Type the name of a LyX function. If the function takes any arguments, you can
type them in after the function name, using a space to separate the two. Then
hit “Return.” You can use tab to auto-complete commands.

Examples:

e Example #1:

Click on the minibuffer with the mouse. Type “accent-acute” followed by
the “Return” key. Now type the letter “u”. You should get the character

[{%S4)

u

e Example #2: Commands with Arguments:

Type “M-x". Now type “layout LyX-Code” followed by the “Return” key.
The current paragraph will now be in the LyX-Code environment. You
could have specified any other valid paragraph environment as an argu-
ment to the layout command.

See Also: accent-acute; layout.
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3.3.5 command-prefix

Default Bindings:

Menu - ?
Toolbar - ?
Keyboard - ?

Purpose: 7
Usage: 7

Examples: ?

See Also: ?
3.3.6 copy
Default Bindings:
Menu - Edit> Copy
Toolbar - Fifth button from the left.

Two pages with a -+ sign.
Keyboard - M-e o (standard).

C-c or C-Insert in cua.bind.

M-w in emacs.bind.

Purpose: Places a copy of the previously selected text into the paste buffer.

Usage: Select text, either with the mouse cursor or by motion selection com-
mands, then either execute cut by either following the menu commands or
pressing the appropriate keystrokes.

See Also: cut; paste.

3.3.7 cut
Default Bindings:
Menu - Editr Cut
Toolbar - Sixth button from the left.

An open pair of scissors.
Keyboard - M-e ¢ (standard).

C-x or S-Delete in cua.bind.

C-w in emacs.bind.
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Purpose: Removes previously selected text and places the removed text into
the copy paste buffer.

Usage: Select text to be removed, either with the mouse cursor or by motion
selection commands, then execute copy by either following the menu commands,
selecting the toolbar icon, or pressing the appropriate keystrokes.

See Also: copy; paste.

3.3.8 delete-backward
Default Bindings:

Keyboard - Backspace .
Purpose: Deletes the character to the left of the cursor.

Usage: Self-explanatory. If the cursor is at the beginning of a paragraph, two
things may happen. First, if the previous and current paragraph have the same
type of paragraph environment, LyX joins the two paragraphs. If the two have
different environment types, IyX will most likely not? join them and simply
move the cursor to the end of the preceding line.

See Also: delete-forward; word-delete-forward; word-delete-backward; line-
delete-forward; line-delete-backward.

3.3.9 delete-forward
Default Bindings:

Keyboard - Delete (standard).
C-d in emacs.bind.

Purpose: Deletes the character to the right of the cursor.

Usage: Self-explanatory. If the cursor is at the end of a paragraph, two things
may happen. First, if the next and current paragraph have the same type of
paragraph environment, LyX joins the two paragraphs. If the two have different
environment types, LyX will most likely not* join them and simply move the
cursor to the end of the preceding line.

3“most likely not” means that the action depends on the specific paragraph environments

involved. Play around and see what happens.
4“most likely not” means that the action depends on the specific paragraph environments
involved. Play around and see what happens.
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See Also: delete-backward; word-delete-forward; word-delete-backward; line-
delete-forward; line-delete-backward.

3.3.10 depth-decrement
Default Bindings:

Keyboard - M-p Left (standard).
M-S-Left in cua.bind.

Purpose: To decrease the paragraph environment depth.
To un-nest two nested paragraph environments.

Usage: To change the depth of a single paragraph, simply move the cursor
into that paragraph and invoke depth-decrement. If you want to change the
depth of a group of paragraphs, select the group with the mouse and then invoke
depth-decrement.

This command “wraps.” Namely, if you reach the outermost environment
depth, depth-decrement move the paragraph to the innermost environment
depth.

See Also: depth-next; depth-increment.

3.3.11 depth-increment
Default Bindings:

Menu - Layout > Change Environment Depth

Toolbar - Fifth button from the right.
Icon indicates doubly indented text bounded by arrows.

Keyboard - M-p Right (standard).
M-S-Right in cua.bind.

Purpose: To increase the paragraph environment depth.
To nest two paragraph environments.

Usage: To change the depth of a single paragraph, simply move the cursor
into that paragraph and invoke depth-increment. If you want to change the
depth of a group of paragraphs, select the group with the mouse and then invoke
depth-increment.

This command “wraps.” Namely, if you reach the innermost environment
depth, depth-increment move the paragraph to the outermost environment
depth.
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See Also: depth-decrement; depth-next.

3.3.12 depth-next
Default Bindings:
Keyboard - M-l v.

Purpose: This command is simply an alias for depth-increment.

See Also: depth-increment.

3.3.13 down
Default Bindings:
Keyboard - Down (standard).

C-n in emacs.bind.

Purpose: Moves the cursor down one line. If the cursor starting-position is
at the bottom of the screen-display, the buffer scrolls upward to display the new
current line about 1/4 of the screen-height from the bottom of the screen.

See Also: char-forward; char-backward; word-forward; word-backward; line-
begin; line-end; tab-forward; up; screen-up; screen-down; buffer-begin; buffer-
end.
3.3.14 down-select
Default Bindings:

Keyboard - S-Down
Purpose: To select text from the current cursor position to the same position

one line down. If the next line is shorter than the current line, the cursor simply
moves to the end of the next line.

See Also: down;

backward-select; forward-select; up-select; word-forward-select; word-backward-
select; line-begin-select; line-end-select; screen-up-select; screen-down-select; buffer-
begin-select; buffer-end-select.

3.3.15 drop-layouts-choice
Default Bindings:
Keyboard - M-p c (standard).
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Purpose: Opens up the combobox for selecting paragraph environments, which
is to the left of the toolbar.

Usage: Once the combobox is open, you can use the cursor keys to select a new
paragraph environment. Hitting “Return” chooses the paragraph environment
currently highlighted. Hitting “Escape” cancels the operation and closes the
combobox.

See Also: layout.

3.3.16 error-next

Default Bindings:

Menu - Edit> Go to Error

Keyboard - M-e e (standard).
C-g in cua.bind.

Purpose: Find the next ETEX error in the buffer.

Usage: You can only use this command under two conditions:

1. You’ve recently invoked buffer-typeset, buffer-typeset-ps, buffer-view,
buffer-view-ps, buffer-chktex or print to run ITEX on your docu-
ment.

2. ITEX found errors in the document.

If this happens, LyX will find the errors and mark them in the document with
a box containing the word “Error”.

Examples: It’s not easy to provide an example for this one. If you don’t know
ETEX, and never intend to insert any ITEX code into your LyX documents, you
might not need to worry about this command. It’s here for those users who do
know IXTEX and might enter incorrect I TEX code into their documents.

See Also: buffer-typeset; buffer-typeset-ps; buffer-view; buffer-view-ps; buffer-
chktex; print.

34 F

3.4.1 figure-insert
Default Bindings:
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Menu - Insert > Figure

Toolbar - Second button from the right.
A picture embedded in text.

Keyboard - M-ig
Purpose: Insert graphics in the current document.

Usage: This function opens the Figure panel, which contains two options:

1. Encapsulated Postscript

2. Inlined EPS

You'll get slightly different behavior depending on which type you select.?

Placement is the difference in the two options. “Inlined EPS” inserts the
graphics within the current line, as if it were a normal character. This can
have remarkably bizarre results on the line spacing if the imported graphics is
very tall. The other option, “Encapsulated Postscript”, breaks the current line
on either side of the figure, separating it from the text.

Note that this function merely creates a box for the appropriate graphics.
You must still choose the file to import. For PostScript®) files, double click on
the box, which will initially contain only the letter “F”, to open the EPS Figure
panel. You can now use the options in the EPS Panel to select and even display
an encapsulated PostScript®) file.

Examples: Currently, none provided. This will change at some point in the
future.

See Also: EPS Figure panel. [Ed. Note - To be added. - jw.]

3.4.2 find-replace
Default Bindings:

Menu - Edit> Find & Replace

Keyboard - M-e f (standard)
C-f in cua.bind or
C-s and M-% in emacs.bind.

Purpose: To search for text and, if desired, replace it with other text.

5This panel previously had a third option, “IATEX or TEX”, for inclusion of IATEX graphics.
This function is now provided by means of the Insert>Include File menu entry.
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Usage: Invoking this command opens the Find & Replace panel. All searches
start at the current cursor position. The target text is placed in the “find” box.
The two arrow buttons choose the search direction. If LyX finds the text, the
cursor moves to the text and remains at the new position. The target text may
be optionally replaced with alternate text placed in the “replace” box.

The search is not case sensitive unless you have checked the “case sensitive”
button. If you check the “Match word” button, then the search will only match
on complete words, so “Manual” will not be found, when searching for “Manuals”.

See Also: TBD.

3.4.3 font-bold
Default Bindings:

Menu - Layout > Bold Style and
Layout > Character... to open the “Character Layout” popup

Character Layout: option “Bold” from the “Series” list

Keyboard - M-I ¢ [to open the “Character Layout” popup]
M-I b, or M-c b (standard)
C-b in cua.bind.

Purpose: Changes the font to an emboldened series or, if the font is already
emboldened, reverts to the default series.

Usage: Rather than repeat the same thing for all 9 font selection functions,
we’ll describe the generic behavior of the font functions here. Some of the font
commands have a toolbar button, others have a menu selection. All of them are
in the Character Layout popup.

All of the font commands do the following to words:

1. If the cursor is in the middle of a word [between two whitespaces|, the
entire word changes to the new font.

2. If the cursor is at the beginning or end of a word, the font commands only
affect any subsequently typed text.

3. You can also tack text in a different font onto a word. Just move the
cursor out of the word to shut off the font, otherwise, you’ll change the
whole word into a single font.

You can also change the font of a block of text by selecting it with the mouse
[or with the keyboard] and then invoking the font command.

Eight of the font commands, font-code, font-emph, font-roman, font-sans,
font-size, font-smallcaps, font-underline, and font-bold, are toggles.
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They will remove a font if text is already in it and deactivate a font if it’s
active.

LyX automatically uses the font of the word next to the cursor. If the cursor
is in the middle of a word, it uses the font of the text to the right of the cursor.

One last thing: we’ve provided this function because ITEX has a bold font
series. We know that many users are used to using boldface for emphasis, and
you can make this the default emphasized font by putting the correct com-
mand in the WTEX preamble. However, we suggest that you use font-emph to
emphasize any text and only use font-bold when appropriate.

Examples: This is an example of a bold font series:
This is bold text.

Suppose you have this sentence:
Here is some text.

If you put the cursor in the word “some” and invoke font-bold, you get:
Here is some text.

If you take the first example, select the words “This is,” and invoke font-bold,
you get:

This is bold text.

Now put the cursor at the end of the word “text.” Delete the period, invoke
font-bold, and type in some text. You’ll get:

This is bold text and this is not.

If you take the sentence, “Here is some text,” put the cursor before the “t” in
the word “text”, invoke font-bold, and type in some text, you’ll get:

Here is some newly added text.

Now put the cursor after the “d” in “added”, and type “ funky ” [it’s important
that you type the spaces, too]. You'll get:

Here is some newly added funky text.

Lastly, we’ll demonstrate mixed fonts. Again, start with the sentence, “Here is
some text.” We can do the following:

Here is something boldtext.

SFor example, to make reference to a vector in the body of the text, many mathematician
use a bold series.
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...by 1) placing the cursor after the “e€” in “some”; 2) invoking font-bold;
3) typing “thing”; 4) placing the cursor before the “t” in “text”; 5) invoking
font-bold; 6) typing “bold”; and 7) moving the cursor out of the word.

The last step automatically shuts off the bold font. Ly X automatically uses
the font of the current word [the word next to the cursor]. If you had not moved
the cursor, but instead tried to turn off bold font by invoking font-bold again,

Here is something boldtext.

...would have been the result. If you’d tried to turn off bold font by invoking
font-default,

Here is something boldtext.
...would have been the result. Now let’s return to:
Here is something boldtext.

We'll try adding text in the middle of the words. Put the cursor between the
“e¢” and the “t” in “something”, type “ly”, move the cursor between the “d” and
“t” in “boldtext”, and type “old”. This is what you’ll get:

Here is somelything boldoldtext.

Hopefully, these examples helped you understand how the font commands
work. All 9 commands listed below in “See Also” work the same way, so the
above examples hold for them, too.

See Also: Character Layout popup; [Ed. note - to be added. -jw]
font-bold; font-code; font-default; font-emph; font-roman; font-sans; font-
size; font-smallcaps; font-underline.

3.4.4 font-code
Default Bindings:

Menu - Layout > Character... to open the “Character Layout” popup
CharacterLayout: option “Typewriter’ from the “Fam-
ily” list
Keyboard - M-l ¢ [to open the “Character Layout” popup]
M-c p (standard)
C-P in cua.bind.

Purpose: Changes the font to the typewriter family, or, if the font is already
in this family, reverts to the default family.
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Usage: A lot of the usage for font-code works the same way as font-bold,
so see the entry for font-bold to get an idea for how to use font-code.

Note that font-code shuts off font-roman and font-sans if either of these
families is active.

Examples: Here is an example of the typewriter font family, which font-code
selects:
This is Typewriter font.

See Also: Character Layout popup; [Ed. note - to be added. -jw]
font-bold; font-roman; font-sans.

3.4.5 font-default

Default Bindings:

Keyboard - M-c Space
Purpose: Changes the font to the default font.

Usage: A lot of the usage for font-default works the same way as font-bold,
so see the entry for font-bold to get an idea for how to use font-default.

Examples: Suppose you had this mess in your text:

HelloI'm a really weird sentence and MY NAME IS DeliRium.
Select this text and invoke font-default. You’ll change it to:

Hello I'm a really weird sentence and my name is Delirium.

See Also: Character Layout popup; [Ed. note - to be added. -jw]
font-bold.

3.4.6 font-emph
Default Bindings:

Menu - Layout > Emphasize Style and
Layout > Character... to open the “Character Layout” popup
CharacterLayout: option “ltalic’ from the “Shape” list
Toolbar - Button #7 from the left.
An exclamation mark.

Keyboard - M-l ¢ [to open the “Character Layout” popup]
M-c e, and M-l e (standard)

C-e in cua.bind.
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Purpose: Changes the font shape to the italic shape, or, if the font is already
in this shape, reverts to the default font shape.

Usage: A lot of the usage for font-emph works the same way as font-bold,
so see the entry for font-bold to get an idea for how to use font-emph.

Note that font-emph shuts off font-smallcaps if that shape is active.

Many new users wonder why this isn’t called “font-italic,” and why boldface
and underlined text don’t have their own menu entries or toolbar buttons. LyX
has adopted a convention from ETEX: specify what you want to do and let
the computer take care of how to do it. The italic font shape is the standard
way to emphasize text in typesetting. LyX [and IATEX] has also adopted this
convention. You can, of course, change which font is the emphasized font by
making the appropriate changes to the ATEX preamble, although this will only
affect the final output. There are also some interesting things that BTEX will
do to emphasized text that IyX can’t [yet] display. It will still be in the final
output. For example, INTEX does certain things for emphasized emphasized
text automatically. If you used a specific font, you’d need to do the same thing
manually, using specific font changes.

In short, the IyX team strongly recommends that you use font-emph to
emphasize any text [this includes book titles] and save any specific font command
for those few special cases where you need to specify exactly how the text is
typeset.

Examples: Here’s an example of emphasized text:

Always use font-emph instead of specific font names!

See Also: Character Layout popup; [Ed. note - to be added. -jw]
font-bold; font-smallcaps.

3.4.7 font-free
Default Bindings:

Menu - Main > Item

Toolbar - Button # from the left.
Brief description of button icon.

Keyboard - None.

Purpose: Changes the font settings to the most recent setting in the Character
pop-up.

Usage: Description.

Examples: Examples.
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See Also: Other entries or documents. Separate many references by either a

€@

;7 or place in multiple paragraphs.

3.4.8 font-roman

Default Bindings:

Menu - Layout > Character... to open the “Character Layout” popup
CharacterLayout: option “Roman” from the “Family” list

Keyboard - M-I ¢ [to open the “Character Layout” popup|
M-c r (standard).

Purpose: Changes the font to the roman family, or, if the font is already of
this family, reverts to the default font family.

Usage: A lot of the usage for font-roman works the same way as font-bold,
so see the entry for font-bold to get an idea for how to use font-roman.

Note that font-roman shuts off font-code and font-sans if either of these
families is active.

Examples: Here is an explicit use of the roman font family:
This is Roman font.

Note that roman is the default font family.

See Also: Character Layout popup; [Ed. note - to be added. -jw]
font-bold; font-code; font-roman; font-sans.

3.4.9 font-sans
Default Bindings:

Menu - Layout > Character... to open the “Character Layout” popup

CharacterLayout: option “Sans Serif” from the “Family”
list

Keyboard - M-I ¢ [to open the “Character Layout” popup]
M-c s (standard).

Purpose: Changes the font shape to the sans serif family, or, if the font is
already of this family, reverts to the default font family.



58 CHAPTER 3. BINDABLE FUNCTIONS

Usage: A lot of the usage for font-sans works the same way as font-bold,
so see the entry for font-bold to get an idea for how to use font-sans.

Note that font-sans shuts off font-code and font-roman if either of these
families is active.

Examples: Here is an example of the Sans Serif font family:

This is the Sans Serif font family.

See Also: Character Layout popup; [Ed. note - to be added. -jw]
font-bold; font-code; font-roman.

3.4.10 font-size
Default Bindings:
Menu - Layout > Character... to open the “Character Layout” popup

CharacterLayout: Any item from the “Size” list
Keyboard - The M-s prefix, plus one of the following keys:

M-s t

M-s 1 "font-size tiny"

M-s s

M-s 2 "font-size small"

M-s n

M-s 3 "font-size normal"

M-s |

M-s 4 "font-size large"

M-s S-L

M-s 5 "font-size larger"

M-s S-A

M-s 6 "font-size largest"

M-s h

M-s 7 "font-size huge"

M-s g

M-s S-H

M-s 8 "font-size giant"
Also:

M-I ¢ [to open the “Character Layout” popup]

Purpose: Change the font size.
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Usage: This command requires an argument, which is the font size. You
must provide the argument in the “\bind” command if you use font-size in a
keybinding file, or in the minibuffer if you use command-execute to invoke it.”

ETEX describes font sizes in relative values. LyX uses the following terms:
tiny, small, normal, large, larger, largest, huge, giant. The normal size can be
set to 10pt, 11pt, or 12pt, with the other sizes set proportionally.

A lot of the usage for font-size works the same way as font-bold, so see
the entry for font-bold to get an idea for how to use font-size.

You should avoid using font-size unless you need to do some fine-tuning.
Never use font-size to make titles or section headings; LyX already does this
for you and in a much better fashion.

Examples: Here are all eight font sizes:

uny, small, normal, large, larger, lal"gest, huge, gl_
ant.

See Also: Character Layout popup; [Ed. note - to be added. -jw]
command-execute;
font-bold.

3.4.11 font-smallcaps

Default Bindings:

Menu - Layout>Noun Style and
Layout > Character... to open the “Character Layout” popup

CharacterLayout: option “Small caps” from the “Shape”
list

Toolbar - Button #8 from the left.
A person.

Keyboard - M-I ¢ [to open the “Character Layout” popup|
M-I n and M-c ¢ (standard)

Purpose: Changes the font shape to the small caps shape, or, if the font is
already of this shape, reverts to the default font shape.

7 Editor’s note: Don’t do this - there is a bug. For some reason, font-size crashes LyX
at the moment. - jw 10/6/96
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Usage: A lot of the usage for font-smallcaps works the same way as font-bold,
so see the entry for font-bold to get an idea for how to use font-smallcaps.
Note that font-smallcaps shuts off font-emph if that shape is active.
The small caps shape is typically used for proper names. Some countries
use this convention more frequently than the US does, hence its prominence in
LyX.

Examples: Here’s what the small caps shape looks like:
THIS IS ALL IN THE SMALL CAPS FONT SHAPE.

See Also: Character Layout popup; [Ed. note - to be added. -jw]
font-bold; font-emph .

3.4.12 font-state
Default Bindings:

Menu - Main > Item

Toolbar - Button # from the left.

Brief description of button icon.

Keyboard - None.
Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

€@

;7 or place in multiple paragraphs.

3.4.13 font-underline
Default Bindings:

Menu - Layout > Character... to open the “Character Layout” popup
CharacterLayout: option “Underbar” from the “Bar” list

Keyboard - M-l ¢ [to open the “Character Layout” popup]
C-u or M-c u (standard).

Purpose: Adds an underbar to subsequent or selected text.
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Usage: A lot of the usage for font-underline works the same way as font-bold,
so see the entry for font-bold to get an idea for how to use font-underline.

The LyX team has provided this function only for compatibility with ETEX.
We know that many users are used to underlining text for emphasis or for book
titles. While you might need to do this on a typewriter, LyX is not a typewriter,
nor should you use it like one. Now, you could make this the default emphasized
font by putting the correct command in the IWTEX preamble. However, we
suggest that you use font-emph to emphasize any text, including book titles,
and avoid using font-underline at all.®

Examples: Here’s an example of the underbar font attribute:

Avoid using underlined text!!!

See Also: Character Layout popup; [Ed. note - to be added. -jw]
font-bold.

3.4.14 footnote-insert
Default Bindings:

Menu - Insert > Footnote

Toolbar - Button # 7 from the right.
A page with an arrow pointing to lines at the bottom of
the page.

Keyboard - M-if
Purpose: To insert a footnote.

Usage: Use the keyboard, menu, or toolbar to insert a footnote. A red box
appears on the next line. If you're in the middle of a line, the line appears to
break around the box [it doesn’t really]. Anything you enter in the box will be
in the footnote.

To the left of the red box is another, smaller box with the word “foot” written
in red on a grey background. Click on this box once with the left mouse button
to close the footnote. A closed footnote looks like the word “foot” written as a
superscript in red.

You can also open and close footnotes, as well as other types of notes and
labels, with the open-stuff command. See its entry for keybindings.

8There is one - and only one - case that we can think of where you might need to use
font-underline. Suppose you’re writing the bibliography of a journal article. The journal
you’re submitting this article to typesets all volume numbers in an underlined font, and
wishes all submissions to do the same. This is perhaps the only time you’d need to use
font-underline.
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One last note: even though footnotes in LyX appear unnumbered, they are.
ETEX does the numbering for you, as well as putting the footnote at the bottom
of the correct page, when it processes your file.

Examples: This? is a footnote.

See Also: open-stuff; marginpar-insert;
Tricks for Footnotes and Marginpars in Eztended Features.

3.4.15 forward-select
Default Bindings:

Keyboard - S-Right

Purpose: Highlight a single character to the right of the cursor. If the cursor
is at the end of a line, the cursor moves to the beginning of the next line, and the
whitespace in between is selected. The selected text is shown in reverse-video.

See Also: char-forward;

backward-select; up-select; down-select; word-forward-select; word-backward-
select; line-begin-select; line-end-select; screen-up-select; screen-down-select; buffer-
begin-select; buffer-end-select.

3.5 G-K

3.5.1 hfill-insert
Default Bindings:

Menu - Insert > Special Character > HFill
Keyboard - C-ior M-i h

Purpose: Insert a BTEX \hfill command.

Usage: The I'TEX \hfill stands for “horizontal fill.” As the name implies,
an HFill fills in the current line with blank space. You can put it at the begin-
ning or end of a line, which will force the line against the right or left margin,
respectively. However, an HFill is most useful in the middle of a line. The
example explains it best. The HFill has pushed the text on either side of it to
the left and right margins.

Important Note: by a “margin,” we do not mean the page margins. We mean
the environment margin. For example, if your document has two columns per

9Hi! I'm a footnote!
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page, an HFill fills in the line to the left and right margin of the column, not
the entire page. If you're in a table cell, HFill fills to the cell borders, and so
on.

You should only use hfill-insert for fine tuning. Iy X has better ways to
justify and format text.

Examples: An \hfill command here has pushed this text apart.

See Also: Editor’s Note: Eventually, vfills or the Paragraph popup. -jw

3.5.2 hyphenation-point-insert
Default Bindings:

Menu - Insert > Special Character > Hyphenation Point

Keyboard - M-i Minus (standard).
C-Minus in cua-bind.

C-h in emacs-bind.
Purpose: Insert a manual hyphenation point via the ITEX \- command.

Usage: While ETEX is normally able to hyphenate most words, it has prob-
lems with other words, especially non-English words and technical terms. This
command allows you to tell BTEX to hyphenate a single instance of a word that
ITEX would otherwise be unable to hyphenate.

To allow I¥TEX to properly hyphenate gnomon, you type it as gno\-mon,
where you insert the “\-” by means of the hyphenation command. Use this
command to do the same in IyX [see the example].

Note: To tell WTEX how to hyphenate all instances of a word in a docu-
ment, insert a ATEX \hyphenation{} command in the preamble,!® where the
argument is a space-delimited list of the words to be hyphenated, with the
hyphenation points noted by dashes, as in \hyphenation{gno-mon gno-mons
gno-mon-1ly}.

Examples: This is what gnomon looks like in Iy’X when hyphenated.

See Also: 7

3.5.3 index-insert

Default Bindings:

Menu - Insert > Index entry

10Edit the preamble from the menu by selecting Layout, then IATEX Preamble .
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Purpose: Add an entry that KTEX can use to generate an index entry.

Usage: KTEX has the capability to compile an index based on keywords
marked in the text. Within IyX, this is done using index-insert immediately
adjacent to the word or phrase to be placed in the index. Note that leaving a
space in between can occasionally result in the page number appearing in the
index to be off by one page.

When using index-insert from the minibuffer, an argument can be used to
give the text to use in the index entry. Regardless of how the entry was created
in IyX, clicking on the index inset gives an editable popup window to allow
changes in the entry.

Examples: Here is what an index entry looks like.

See Also: index-print

3.5.4 index-print
Default Bindings:

Menu - Insert > Lists and TOC» Index list
Keyboard - M-iti

Purpose: Instruct BTEX to print the index.

Usage: index-print causes XTEX to read index entries created by index-insert,
generate an index, and add it to the output document. Within IyX, the only
visible effect of index-print is to create an inset labeled Print Index.

See Also: index-insert

3.5.5 inset-formula-latex-deletable-insert

Default Bindings:

None.

Purpose: I don’t know what this is used for, though it seems to go into a
kind of math-mode.

Usage: 7
Examples: ?

See Also: 7



3.5. G-K 65

3.5.6 inset-formula-latex-insert

Default Bindings:

None.

Purpose: 1 don’t know what this is used for, though it seems to go into a
kind of math-mode.

Usage: 7

Examples: 7

See Also: 7

3.5.7 inset-latex-deletable-insert

Default Bindings:

None.

Purpose: 7

Usage: 7

Examples: 7

See Also: ?

3.5.8 inset-latex-insert

Default Bindings:

None.

Purpose: 7

Usage: 7

Examples: 7

See Also: 7
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3.5.9 keymap-off
Default Bindings:

Menu - Options> Keyboard
Key Mappings: No key mapping
Keyboard - M-k o or M-k x

Purpose: Turn off keyboard character keymapping.

Usage: In addition to the default keymap, the keyboard can have a primary
keymap, a secondary keymap, or both. If you have previously defined and
selected either the primary or secondary keymaps, you can turn-off this selection
by issuing the keymap-off command.

Editor’s Note - We probably need to add some more info. - jw

Examples: ?

See Also: keymap-primary; keymap-secondary.
Keyboard keymapping is described in more detail in. ..

3.5.10 keymap-primary
Default Bindings:

Menu - Options > Keyboard
Key Mappings: Primary key mapping
Keyboard - M-k 1

Purpose: Select the primary keymap.

Usage: Self-explanatory. See keymap-off for more details about using multi-
ple keymaps.

See Also: keymap-off
3.5.11 keymap-secondary

Default Bindings:

Menu - Options > Keyboard
Key Mappings: Secondary key mapping
Keyboard - M-k 2
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Purpose: Select the secondary keymap.

Usage: Self-explanatory. See keymap-off for more details about using multi-
ple keymaps.

See Also: keymap-off

3.5.12 keymap-toggle

Default Bindings:

Menu - Options > Keyboard
Key Mappings: Mapping Switch
Keyboard - M-kt

Purpose: Allows you to toggle back and forth between the primary and sec-
ondary keymaps (either of which can be set to a value of default).

Usage: Self-explanatory. See keymap-off for more details about using multi-
ple keymaps.

See Also: keymap-off

3.6 L

3.6.1 label-insert

Default Bindings:

Menu - Insert > Label
Input: (enter label name in input box)

Keyboard - M-il

Purpose: Insert a label (and create a character string label key for it) for use
in a cross-reference to either the current environment entity or the printed page
number of the label location.
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Usage: This command inserts a N TEX \label{key} command into the doc-
ument, which contains a case-sensitive alphanumeric label key that you define.
This command allows IMTEX to track the current environment and printed page
number for subsequent!! cross-reference via the ref-insert command. The
current environment is the section, table, figure, equation, enumerated item,
etc., that the label is within. Note that the actual printed label is not displayed
until you view or print your document; LyX displays instead on the screen the
symbolic label, which is the character string label that you defined.

Note that you can’t define labels for math equations using this command.
LyX labels equations using a combination of the math-number command and the
actual A TEX command \label{key}. See the User’s Guide for more information
about labelling and numbering equations.

Examples: If the current environment is a section, as it is here at this point,
you can insert a label with the following result:. This label can then be refer-
enced, and the result will be the section number for this section, as Section 3.6.1.

See Also: ref-insert; math-number.
You can find further description of the BTEX labeling and cross-referencing
method in the IyX User’s Guide or any I'TEX user’s guide.

3.6.2 latex-view-log

Default Bindings:
Menu - Edit> View IKTEX Log
Keyboard - M-ew

Purpose: Displays the log file produced by IATEX.

Usage: Self-explanatory.

3.6.3 layout
Default Bindings:

Toolbar - Pull-down box at the left end of the toolbar.
Keyboard - M-p prefix plus one of the following:

M-p 1 “layout Chapter”
M-p 2 “layout Section”
M-p 3 “layout Subsection”

1 Actually, it doesn’t need to be a subsequent reference. You can reference a label before it
is defined, but you must then run IATEX multiple times to allow I4TEX to resolve these types
of references.
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M-p 4 “layout Subsubsection”
M-p 5 “layout Paragraph”
M-p 6 “layout Subparagraph”
M-p a “layout Abstract”

M-p S-A  “layout Author’
M-p M-a  “layout Address”
M-p C-a  “layout RightAddress”

M-p b “layout Itemize”
M-p S-B “layout Bibliography”
M-p c “layout LyX-Code”

M-p S-C  “layout Comment”
M-p M-c  “layout Caption”

M-p d “layout Description”
M-p S-D  “layout Date”

M-p e “layout Enumerate”

M-p f “layout ShortFoilhead”
M-p S-F  “layout Foilhead”

M-p i “layout Itemize”

M-p | “layout List”

M-p S-L  “layout LaTeX”

M-p n “layout Enumerate”

M-p q “layout Quote”

M-p S-Q “layout Quotation”

M-p r “layout ShortRotatefoilhead”
M-p S-R  “layout Rotatefoilhead”
M-p s “layout Standard”

M-p t “layout Title”

M-p v “layout Verse”

M-p x “layout LaTeX”

M-p S-at  “layout Sectionx”
M-p S-numbersign “layout Subsectionx”
M-p S-dollar “layout Subsubsection*”

Purpose: To select a paragraph environment.

Usage: This function requires an argument, which is the name of the para-
graph environment to use. Yes, we realize the nomenclature is confusing. Un-
fortunately, we’ve changed our terminology but not the function names.

There are more possible arguments than those listed in the keybindings. In
fact, the possible arguments change depending on what document class you’re
using. In any case, there are so many different paragraph environments that
we couldn’t go into detail about each one here. [Editor’s Note- Maybe we need
another chapter, just for the layouts? - jw]
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See Also: The appropriate section of UserGuide.lyx.

3.6.4 layout-character
Default Bindings:

Menu - Layout > Character
Character Layout: (controls for character font settings)
Keyboard - M-l ¢

Purpose: Activates the Character Layout pop-up, which allows you to control
the character family, series, shape, size, and underlining font details.

Usage: You can change the character appearance just once, for selected text,
or for all subsequently typed text.

Yes, we realize the nomenclature is confusing. Unfortunately, we’ve changed
our terminology but not the function names.

See Also: layout-paragraph; layout-document.

3.6.5 layout-document

Default Bindings:

Menu - Layout > Document

Document Layout: (controls for document format set-
tings)
Keyboard - M-Id

Purpose: Activates the Document Layout pop-up, which allows you to control
parameters affecting the entire document, including: class, pagestyle, default
font type and size, language, paper size, number of paper sides and orienta-
tion, number of columns, paragraph separation method and spacing, section
numbering and table of contents depth, and other parameters.

See Also: layout-character; layout-paragraph.

3.6.6 layout-paragraph
Default Bindings:

Menu - Layout > Paragraph

Paragraph Layout: (controls for paragraph format set-
tings)
Keyboard - M-l p
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Purpose: Activates the Paragraph Layout pop-up, which allows you to con-
trol parameters affecting the current paragraph, including: alignment, vertical
spacing above and below the paragraph, line spacing, page breaking, indention,
and label width (for appropriate paragraphs).

Usage: You may make changes either to the current paragraph or to a group
of selected paragraphs. Changes made to the current paragraph [or the selected
group]| do not affect other paragraphs.

Yes, we realize the nomenclature is confusing. Unfortunately, we’ve changed
our terminology but not the function names.

See Also: layout-character; layout-document.

3.6.7 layout-preamble
Default Bindings:

Menu - Layout>LaTEX Preamble

IETEX Preamble: (edit window for direct modification
of the BTEX preamble)

Keyboard - M-I |

Purpose: Activates the IATEX Preamble pop-up, which allows you to directly
make additions to the IXTEX preamble that LyX inserts in the ITEX version of
the document.

Usage: In the BTEX preamble, you can insert non-standard WTEX parameter
settings or BTEX commands.

Each document has its own preamble. Iy’X currently adds certain commands
to the preamble based on settings you’ve chosen from within LyX. Some things
LyX just can’t do yet, but ETEX can. Or, you may want to use some custom
IATEX macros. The IATEX Preamble popup is where to do it.

Example: The following is a typical preamble that changes default settings
for twocolumn mode, creates a simple custom IWTEX command for later use in
this document, and then reads in some other personal settings and/or macros
from an external file. Remember, if you want your documents to be portable,
you need to bundle any such external files with the document file(s):

\columnsep 10pt
\columnseprule 2pt
\newcommand{\astm} [2] {#1\,#2}
h

\input{\home\homenode\myname\latex\macros\my_macros.def}
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See Also: The appropriate chapter in LyX User’s Guide.

3.6.8 layout-quotes
Default Bindings:
Menu - Layout > Quotes

Quotes: (controls for setting desired quotation marks)
Keyboard - M-l q

Purpose: Activates the Quotes pop-up, which allows you to set the type of
quote marks used by LyX.

Usage: Self explanatory. Different languages use different symbols for the de-
fault quotes. For example, French uses «», not ‘. Selecting a different type of
quote changes the behavior of the “ and ' keys. LyX supports a bunch of different
quotes. If you need a special one not present, contact lyx-devel@lists.lyx.org
and we’ll see what we can come up with.

See Also: 7

3.6.9 line-begin
Default Bindings:
Keyboard - Home in cua.bind.
C-a in emacs.bind.

Purpose: Move the cursor to the beginning of the current line.

See Also: char-forward; char-backward; word-forward; word-backward; line-
end; tab-forward; up; down; screen-up; screen-down; buffer-begin; buffer-end.

3.6.10 line-begin-select
Default Bindings:

Keyboard - S-Home

Purpose: Select (highlight) text from the current cursor location to the be-
ginning of the current line. The selected text is shown in reverse video.

See Also: line-begin;

backward-select; forward-select; up-select; down-select; word-forward-select;
word-backward-select; line-begin-select; line-end-select; screen-up-select; screen-
down-select; buffer-begin-select; buffer-end-select.
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3.6.11 line-delete-forward
Default Bindings:

Keyboard - C-k or M-e k

Purpose: Delete text from the current cursor location to the end of the screen
line.

Usage: If the cursor is at the end of the line there is no action. If the cursor is
at the beginning of the line, the text of the entire line is deleted but the empty
line is retained for insertion of new text.

See Also: 7

3.6.12 line-end
Default Bindings:

Keyboard - End in cua.bind.

C-e in emacs.bind.
Purpose: Move the cursor to the end of the current line.

See Also: char-forward; char-backward; word-forward; word-backward; line-
end; tab-forward; up; down; paragraph-up; paragraph-down; screen-up; screen-
down; buffer-begin; buffer-end.

3.6.13 line-end-select
Default Bindings:

Keyboard - S-End

Purpose: Select (highlight) text from the current cursor location right to the
end of the current line, in the current buffer. The selected text is shown in
reverse video.

See Also: line-end;

backward-select; forward-select; up-select; down-select; word-forward-select;
word-backward-select; line-begin-select; screen-up-select; screen-down-select; buffer-
begin-select; buffer-end-select.
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3.6.14 lyx-quit
Default Bindings:

Menu - File > Exit
Keyboard - M-f x (standard).
C-q in cua.bind.
C-x c or C-x C-c in emacs.bind.

Purpose: Exit LyX and close all buffers and windows.

Usage: After entering the command, a pop-up for each open and modified
buffer appears, asking you if you want to save that buffer. This only happens if
any open documents need saving.

At this point, one of two things happen. If you executed lyx-quit from the
keyboard, LyX simply quits. If you used Quit from the File menu, however, LyX
asks you if you really want to quit.

If you decide to customize the keybinding for this one, choose a complicated
key sequence.

See Also: ?

3.7 M

3.7.1 marginpar-insert

Default Bindings:

Menu - Insert > Margin note

Toolbar - Button 6 from the right.

Text column on the left with a short text column on the
right and an arrow pointing upwards at the shorter text.

Keyboard M-i m
Purpose: Insert a margin note.

Usage: Use the keyboard, menu, or toolbar to insert a marginpar. A red box
appears on the next line. If you’re in the middle of a line, the line appears to
break around the box [it doesn’t really]. Anything you enter in the box will be
in the marginpar.

To the left of the red box is another, smaller box with the word “margin”
written in red on a grey background. Click on this box once with the left mouse
button to close the marginpar. A closed marginpar looks like the word “margin”
written as a superscript in red with an ’!” in the left margin.
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You can also open and close marginpars, as well as other types of notes and
labels, with the open-stuff command. See its entry for keybindings.

One last note: marginpars aren’t supported in minipage environments so
LyX will warn you if you try to.

Examples: This is a marginpar. Marginpar

See Also: open-stuff; footnote-insert;
Tricks for Footnotes and Marginpars in Eztended Features.

3.7.2 mark-off
Default Bindings:

Menu - Main > Item

Toolbar - Button # from the left.

Brief description of button icon.

Keyboard - M-e S-M
Purpose: Turns off selection marking.
Usage: Description.

Examples: Examples.

See Also: mark-on; mark-toggle; cut; copy;

3.7.3 mark-on

Default Bindings:

Keyboard - M-em

C-Q@ in emacs.bind.
Purpose: Description.
Usage: Description.
Examples: FExamples.

See Also: mark-off; mark-toggle; cut; copy;
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3.7.4 mark-toggle
Default Bindings:

Keyboard - C-m in emacs.bind.
Purpose: Toggles selection marking on/off.
Usage: Description.

Examples: Examples.

See Also: mark-off; mark-on; cut; copy;

3.7.5 math-delim
Default Bindings:

Menu - Math > Math Panel

MathPanel: Third button from left to right.
Two square brackets enclosing a blue rectangle.

Purpose: To insert math delimiters [i. e. - parentheses, brackets, etc.].

Usage: Requires two arguments, the left and right delimiters. Each delimiter
can be specified by either a ETEX name or a valid character . Use only one
space between items.

If you use this function from the Math Panel, you’ll get another popup that
allows you to choose the left and right delimiters.

Examples: “math-delim { rangle” result in {) with the cursor at the small
rectangle.

See Also: UserGuide, chapter Math.

3.7.6 math-display
Default Bindings:

Menu - Math > Display

MathPanel: Rightmost button.
A small blue rectangle with two horizontal lines below
and above.
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Purpose: In text mode, this is used to create a new displayed equation. In
math mode it changes the display status of a formula from inlined to display
and vice-versa.

Usage: Self-Explanatory

Examples: This is a displayed equation:

a=b+c
See Also: UserGuide, chapter Math.

3.7.7 math-greek
Default Bindings:

Keyboard - M-mg
Purpose: Enter a single Greek character.

Usage: After invoking this function, the next character you type will be trans-
lated to a Greek character. Anything typed after that character will be a normal
Latin character.

Examples: I'Qag.

See Also: UserGuide, chapter Math.

3.7.8 math-greek-toggle
Default Bindings:

Keyboard - M-m S-G
Purpose: Turn on the math Greek keyboard.

Usage: Every typed Latin character is mapped to Greek until this command
is invoked again. If you leave math mode, the Greek keyboard remains active.

See Also: UserGuide, chapter Math.
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3.7.9 math-insert
Default Bindings:

Keyboard - The M-m prefix, plus one of the following keys:

M-m i "math-insert \int"
M-m o "math-insert \oint"
M-m p "math-insert \partial"
M-m s "math-insert \sqrt"

M-m S-S "math-insert \sum"
Purpose: To insert math objects or symbols.

Usage: Requires an argument, which can be the IXTEX name of either a symbol
or an object. The possible arguments are:

e frac

e int

e oint

e partial
e sqrt

e sum
Examples: “math-insert \int” or “math-insert \frac”.

See Also: UserGuide, chapter Math.

3.7.10 math-limits
Default Bindings:

Keyboard - M-m |

Purpose: To change the appearance of the limits above and below an integral
symbol, a limit, a summation, etc.

Usage: Put the cursor before [i.e. to the left] of the symbol with the limits,
then invoke math-limits.

o0
Examples: This is a normal integral / and this was changed with limits
0

Jo
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See Also: UserGuide, chapter Math.

3.7.11 math-matrix
Default Bindings:

Menu - Math>Math Panel
MathPanel: A grid of 3 x 3 small blue rectangles.

Purpose: To insert a matrix.

Usage: This command requires as arguments the dimensions of the matrix
(two integer numbers separated by an space) and, optionally, the alignment.
The alignment is a word composed of the vertical alignment (b, ¢ or t) and the
horizontal alignments (1, c or r).

Examples: math-matrix 3 3 bccc results in , a 3 x 3 matrix with its

bottom at the baseline and all columns centered.

See Also: UserGuide, chapter Math.

3.7.12 math-mode
Default Bindings:

Menu - Math > Math mode

Toolbar - Second button from the right.
A blue equation.

Keyboard - M-cm
Purpose: Set math mode.
Usage: In text mode you can insert a math expression.

Examples: Most of the entries for math functions have examples of math
mode in them. Here’s another example:

Here is some text. Now suppose I wanted an inlined equation, such as
in my text. I’d use math mode.

A-e”
x+1?

See Also: UserGuide, chapter Math.

3.7.13 math-nonumber

Default Bindings: None
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Purpose: To suppress the number of a line in a numbered equation array.

Usage: The cursor position must be at the line whose number will be sup-
pressed.

Examples: This example contains a two-line, numbered equation. Ordinarily,
both lines get numbered, which makes no sense for this equation:

(+y(z—y) = 2°—ay+ay—y°
= 2% -y (3.1)

Notice that only the bottom line has a number. The top line had its number
suppressed using “math-nonumber”.

See Also: UserGuide, chapter Math.

3.7.14 math-number
Default Bindings:

Keyboard - M-mn

Purpose: Toggles the numbering status of an equation. Changes the KTEX
environment, automatically.

Usage: Self-explanatory

Examples: This is a numbered equation

And this is not

See Also: UserGuide, chapter Math.

3.7.15 math-size
Default Bindings:

Keyboard - M-m?

Editor’s Note - there may be no default binding for this command. - jw
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Purpose: To change arbitrarily the size used by math fonts inside a context.
Provides an interface to the INTEX math mode font size commands.

Usage: Requires one argument. Valid arguments are displaystyle, textstyle,
scriptstyle and scriptscriptstyle.

As for how to use these arbitrary font sizes, see a good IATEX book. You
should use this for fine-tuning only. LyX [and IXTEX] will ordinarily set an
appropriate font size for you.

1
Examples: This is the normal size of a fraction inside text %, and this other —

is the result of using math-size displaystyle. [There’s no visible difference
between the two inside LyX, but there will be a difference once you print.|

See Also: UserGuide, chapter Math;
any good BTEX guide.

3.7.16 melt
Default Bindings:

Menu - Edit > Floats & Insets> Melt

Toolbar - This button is not activated as default.

The icon shows two small “blobs” with an arrow between
them pointing down towards a larger “blob.”

Keyboard - No default keybinding

Purpose: To move the contents of a floating inset to the body at the location
where it appears in the LyX window.

Usage: Place the cursor inside the unfolded float.

See Also: footnote-insert; open-stuff; marginpar-insert
Floats are described in detail in chapter 4 of the Userguide.

3.7.17 menu-open

Default Bindings:

Menu - Main > Item
Toolbar - Button # from the left.
Brief description of button icon.
Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.
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Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

@

;7 or place in multiple paragraphs.

3.7.18 meta-prefix
Default Bindings:

Menu - Main > Item

Toolbar - Button # from the left.
Brief description of button icon.

Keyboard - C-S-M-W-key in filel.bind.
C-S-M-W-key in file2.bind.

Purpose: Description.
Usage: Description.
Examples: Examples.

See Also: Other entries or documents. Separate many references by either a

@

;7 or place in multiple paragraphs.

3.8 N-R

3.8.1 note-insert
Default Bindings:

Menu - Insert > Note
Keyboard - M-in

Purpose: Creates at the current cursor position, and for screen interactive
use only, a IiyX Note, which is visible by the word “Note” within a bright-yellow
box. The box is tied to a pop-up, within which you can insert a message.

Usage: After inserting the note at the desired text position, click on the note
to see bring-up the pop-up, and type-in your message. Neither the box nor the
message appear in the printed output.
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Examples: To the immediate left is an inserted note. Click on the box with
your mouse to see the message.

See Also: note-next; open-stuff.

3.8.2 note-next
Default Bindings:

Menu - Edit> Go to Note
Keyboard - M-en

Purpose: Move the current cursor and screen location to the next Iy X Note
in the current buffer. There is no action if there are no more notes in the
document (or no notes at all).

See Also: note-insert.

3.8.3 open-stuff
Default Bindings:

Menu - Edit>Floats & Insets>Open/Close

Keyboard - C-o
(or use the appropriate mouse button action)

Purpose: Opens a LyX inset for editing or parameter modification.

Usage: Place the cursor to the left of the entity and execute the command.
Or, click on the center of the object with the mouse. open-stuff will open a math-
mode block (left mouse button, single click), figure, note, footnote or margin
note (left mouse button, double-click).

Typically, the object you’re opening is some sort of inset or float. You can
use melt to remove the float and merge the text back into the body of the
document.

See Also: melt.

3.8.4 paste
Default Bindings:

Menu - Edit > Paste

Toolbar - Button #6 from the left.
Schematic of a clipboard with arrow to a document.
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Keyboard - M-ep
C-v or S-Insert in cua.bind.
C-y in emacs.bind.

Purpose: Paste the contents of the paste buffer into the current buffer, at the
current cursor location.

Usage: Upon starting LyX, the paste buffer is initially empty. During a cut or
copy operation, the selected text will be stored in the paste buffer, overwriting
anything previously stored in the buffer.

If a selection is highlighted at the current cursor location, LyX paste inserts
the paste buffer text after the selection. It does not overwrite; it only operates
in insert mode.

See Also: cut; copy.

3.8.5 prefix-arg
Default Bindings:

Menu - ?
Toolbar - ?
‘?

Keyboard - ?
Purpose: 7
Usage: 7
Examples: 7

See Also: 7
3.8.6 protected-space-insert
Default Bindings:

Menu - Insert > Special Character> Protected Blank

Keyboard - C-Space

Purpose: Insert an interword space at which a line break will not be allowed
either on the LyX screen or in the BTEX output.
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Usage: The protected space is represented on the screen as a small, magenta,
“square cup”’ symbol, like this , which if you are reading a printed copy looks
something like L.

This is sometimes also called a “hard space” or a “fixed space” because it is
not resized like other whitespace.

Use the protected space for phrases that you don’t want broken at the end
of a line, or to insert more than one word into certain kinds of headings. For
example, the Description list always treats the first word of the paragraph as an
item label and boldfaces it. If you wanted to use more than one word as an item
label, use protected space between the words.

Never use protected-space as a substitute tab-stop! IyX has far, far better
ways of formatting text, so use them.

Examples: This phrase, “the whole nine yards,” will not be broken at the end
of a line. And if we had a description list with multi-word labels:

entry #1 This is one.

entry #2 This is two. Notice the protected space between the words in the
item label.

See Also: The User’s Guide

3.8.7 quote-insert

Default Bindings:

Keyboard - C-q, S-C-“, M-i ', or M-i S-*

Purpose: Insert a typewriter-style double quote symbol, ", at the current
cursor location.

Usage: On the default keyboard, the grave and apostrophe keys produce
matching single quote characters, and the double-quote key produces context-
sensitive anti-symmetric double quotes. While it should normally be used only
in rare situations, the quote-insert command allows you to easily produce the
less esthetically pleasing typewriter-style double quote symbol.

This command also allows you to create a double-quote character when
you’ve changed the behavior of the " key using the layout-quotes command.

See Also: layout-quotes.



86 CHAPTER 3. BINDABLE FUNCTIONS

3.8.8 redo
Default Bindings:

Menu - Edit> Redo

Keyboard - M-er
C-Z in cua.bind.

Purpose: Attempts to redo the last major editing command that was undone
with the undo command.

Usage: Self-explanatory. redo may not always succeed, or it may redo more
editing than you expected. The only limit to how many times you can perform
a redo is the beginning of the undo buffer.

See Also: undo.

3.8.9 ref-insert
Default Bindings:

Menu - Insert > Cross-Reference
Insert Reference: (cross-reference control panel)

Keyboard - M-ir

Purpose: Insert a cross-reference (using a character string label key), based
on a previously defined label.

Usage: This command inserts either a WTEX \ref{key} or a \pageref{key}
command, as appropriate, into the document. The key parameter is the case-
sensitive alphanumeric label that you previously defined using label-insert.
Executing the ref-insert command brings up the Insert Reference pop-up con-
trol panel, which shows you a selection list of previously defined references. Also
on this panel, you are given the option of referencing either the environment
reference related to that label (like the section number) or the page number at
which the label is located.

The \ref (key) command allows IATEX to track the specified key and sub-
stitute the appropriate cross-reference. The environment referenced can be a
section, table, figure, equation number, enumerated item, etc. Note that the
actual printed label is not displayed until you view or print your document;
LyX displays instead on the screen the symbolic label, which is the character
string label key that you defined.

Note that labels defined in math mode don’t become visible to the Insert Ref-
erence popup until after you close and reopen the document.
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Examples: See label-ref for an example of referencing a section number.
That same label from that example can also be used to reference the page num-
ber at that location; for example, the page number of that location is Page 68.

See Also: label-insert; math-number.
You can find further description of the BTEX labeling and cross-referencing
method in the ILyX User’s Guide or any good ITEX user’s guide.

3.9 S

3.9.1 screen-down

Default Bindings:
Keyboard - PageDown

C-v or C-x ] in emacs.bind.

Purpose: Moves the cursor down one screenful of text while maintaining the
current relative cursor screen position.

Usage: Self-explanatory. Note that repeated screen-down and screen-up
commands will not necessarily return the cursor to its previous location.

See Also: char-forward; char-backward; word-forward; word-backward; line-
begin; line-end; tab-forward; up; down; screen-up; buffer-begin; buffer-end.
3.9.2 screen-down-select

Default Bindings:

Keyboard - S-PageDown

Purpose: Highlights (selects) the text between the starting and ending cursor
positions during a screen-down move. The highlighted text is shown in reverse
video.

See Also: screen-down;

backward-select; forward-select; up-select; down-select; word-forward-select;
word-backward-select; line-begin-select; line-end-select; screen-up-select; buffer-
begin-select; buffer-end-select.

3.9.3 screen-recenter

Default Bindings:

Keyboard - C-lin emacs.bind.
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Purpose: Repositions the screen so that it is centered on the current cursor
location. The position of the cursor in the text does not change.

See Also: ?

3.9.4 screen-up
Default Bindings:

Keyboard - PageUp

C-x [ in emacs.bind.

Purpose: Moves the cursor up one screenful of text while maintaining the
current relative cursor screen position.

Usage: Self-explanatory. Note that repeated screen-down and screen-up
commands will not necessarily return the cursor to its previous location.

See Also: char-forward; char-backward; word-forward; word-backward; line-
begin; line-end; tab-forward; up; down; screen-down; buffer-begin; buffer-end.

3.9.5 screen-up-select

Default Bindings:

Keyboard - S-PageUp

Purpose: Highlights (selects) the text between the starting and ending cursor
positions during a screen-up move. The highlighted text is shown in reverse
video.

See Also: screen-up;

backward-select; forward-select; up-select; down-select; word-forward-select;
word-backward-select; line-begin-select; line-end-select; screen-down-select; buffer-
begin-select; buffer-end-select.

3.9.6 self-insert
Default Bindings:

Menu - Main > Item

Toolbar - Button # from the left.
Brief description of button icon.

Keyboard - None.
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Purpose: Don’t know what this does<ref>.

Usage: 7

Examples: ?

See Also: ?

3.9.7 server-char-after

Default Bindings: None.

Purpose: One of the functions for the Iy X server.
Usage: 7

Examples: Examples.

See Also: server-get-font; server-get-latex; server-get-layout; server-get-name;
server-get-xy; server-notify; server-set-xy.

3.9.8 server-get-font

Default Bindings: None.
Purpose: One of the functions for the Iy X server.
Usage: 7

See Also: server-char-after; server-get-latex; server-get-layout; server-get-name;
server-get-xy; server-notify; server-set-xy.

3.9.9 server-get-latex

Default Bindings: None.
Purpose: One of the functions for the Iy X server.
Usage: 7

See Also: server-char-after; server-get-font; server-get-layout; server-get-name;
server-get-xy; server-notify; server-set-xy.
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3.9.10 server-get-layout
Default Bindings: None.

Purpose: One of the functions for the Iy X server.
Usage:

See Also: server-char-after; server-get-font; server-get-latex; server-get-name;
server-get-xy; server-notify; server-set-xy.

3.9.11 server-get-name

Default Bindings: None.
Purpose: One of the functions for the LyX server.
Usage: 7

See Also: server-char-after; server-get-font; server-get-latex; server-get-layout;
server-get-xy; server-notify; server-set-xy.

3.9.12 server-get-xy
Default Bindings: None.

Purpose: One of the functions for the Iy X server.
Usage: 7

See Also: server-char-after; server-get-font; server-get-latex; server-get-layout;
server-get-name; server-notify; server-set-xy.

3.9.13 server-notify
Default Bindings: None.

Purpose: One of the functions for the Ly X server.
Usage: 7

See Also: server-char-after; server-get-font; server-get-latex; server-get-layout;
server-get-name; server-get-xy; server-set-xy.
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3.9.14 server-set-xy

Default Bindings: None.
Purpose: One of the functions for the Ly X server.
Usage: 7

See Also: server-char-after; server-get-font; server-get-latex; server-get-layout;
server-get-name; server-get-xy; server-notify.

3.9.15 set-color
Default Bindings: None.

Purpose: Change the colors used by LyX.

Usage: set-color required two arguments, the Iy X color name (essentially the
object to be colours) and the display (currently X11) color name.

See Also: The set-color section of the Customization guide.

3.9.16 spellchecker
Default Bindings:

Menu - Edit > Spellchecker

Spellchecker: (control panel for the spellchecker)
or

Options> Spellchecker Options
Spellchecker Options: Start Spellchecker
Keyboard - M-es

Purpose: Start spellchecker.
[Author’s Note: Need more detail here. -<ref>]

See Also: spellcheck popup. [Editor’s Note: To be added later - jw.]

3.9.17 symbol-insert
Default Bindings:

Keyboard - M-cm
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Purpose: This command is simply an alias for the command math-mode.

See Also: math-mode.

3.10 T-U

3.10.1 tab-forward

Default Bindings:

Keyboard - Tab

Purpose: Move the cursor position forward to the left margin at the start of
the next paragraph or list item.

Usage: Note that although other motion commands have a text selection par-
allel, tab-forward does not; there is currently no “tab-forward-select” com-

mand in LyX.

See Also: char-forward; char-backward; word-forward; word-backward; line-
begin; line-end; up; down; screen-up; screen-down; buffer-begin; buffer-end.

3.10.2 table-insert

Default Bindings:

Menu - Edit > Table> Insert table
Table: (table size and insertion control panel)

Toolbar - First button on the right.

Table icon showing a four by four table with gridlines.

Purpose: Inserts a BTEX table (tabular environment) into the text.

Usage: Executing the command creates a pop-up table control panel that
allows you to set the initial number of rows and columns. Hitting either the
control panel OK or Apply buttons inserts the table at the current cursor loca-
tion. Text can then be inserted into any cell of a table by selecting the cell and
typing. The table can be modified by placing the cursor anywhere in the table
and clicking the right mouse button, which brings up a table control menu.
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Examples: Executing the table-insert function at the end of this sentence,
and accepting the default values, results in the following:

[1[2[3[4]5]
Al x y
B X |y
C y | x
D |y X

We took the liberty of adding a little text to the table.

See Also: TBD. We'll think of something, to be sure...

3.10.3 tex-mode
Default Bindings:

Menu - Layout > Tex Style

Toolbar - Fourth button from the right.
Button with TEX on the face

Keyboard - M-l t or M-c t (standard)

C-lin cua.bind.
Purpose: Enter BKTEX code.

Usage: The tex-mode command is a toggle function. When first executed,
tex-mode begins accepting characters as a KTEX command rather than text;
when tex-mode is executed again this action stops. The result must be a valid
and appropriate I’ TEX command, or an error will result when the file is processed

with ITEX.

Examples: The characters accepted as a IWTEX command are shown on the
screen in red, as this example of the BTEX \relax command shows: “”.

See Also: math-mode.

3.10.4 toc-insert
Default Bindings:

Menu - Insert > Lists and TOC > Table of Contents
Keyboard - M-itc
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Purpose: Inserts a table of contents in your document at the current cursor
position.

Usage: The standard location for a table of contents is straight after the title
page. So insert it there for best results.

See Also: toc-view; Table of Contents popup.

3.10.5 toc-view

Default Bindings:

Menu - Edit > Table of Contents
Table of Contents: (table of contents control panel)

Keyboard - M-et
Purpose: This function brings up the Table of Contents pop-up.

Usage: You can update the table of contents using the Update button on
the control panel, but the primary purpose of the Table of Contents pop-up is
browsing.

See Also: toc-insert; Table of Contents popup.

3.10.6 toggle-cursor-follows-scrollbar

Default Bindings: None.
Purpose: To control the movement of the cursor when you use the scrollbar.

Usage: Use this switch to change the way the cursor is handled when you
move the scrollbar. The default behaviour is for the cursor to remain at the
last position you were editing even if you scroll it off the screen. The alternate
behaviour is for the cursor to always be on screen with its position limited by
the topmost or bottommost visible line of text.

It is possible to set the alternate behaviour as the default by adding an entry
in your lyxrc file of the form: \cursor_follows_scrollbar true.

3.10.7 toolbar-add-to
Default Bindings: None.

Purpose: Used in the lyxrc files to add a toolbar button.
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Usage: 7
See Also: toolbar-push.

3.10.8 toolbar-push
Default Bindings: None.

Purpose: Used in the 1yxrc files to add a toolbar button.
Usage: 7
See Also: toolbar-add-to.

3.10.9 undo
Default Bindings:

Menu - Edit>Undo
Keyboard - M-eu

C-z in cua.bind.
C-x u or C-7S-slash in emacs.bind.

Purpose: Undo the last major editing command.

Usage: Self explanatory.

Two things: first, undo has unlimited depth. (Except in the beta-version,
where this feature has been limited to 100 steps for safety). You can keep invok-
ing undo until you run out of changes and the document is back in the state it
was in when you loaded it.

Second, undo does not work everywhere. You cannot undo changes to the
document layout, for example.

See Also: redo.

3.10.10 up
Default Bindings:

Keyboard - Up

C-p in emacs.bind.

Purpose: Moves the cursor down up line. If the cursor starting-position is
at the top of the screen-display, the buffer scrolls downward to display the new
current line about 1/4 of the screen-height from the top of the screen.
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See Also: char-forward; char-backward; word-forward; word-backward; tab-
forward; line-begin; line-end; down; screen-up; screen-down; buffer-begin; buffer-
end.

3.10.11 up-select
Default Bindings:

Keyboard - S-Up

Purpose: To select text from the current cursor position to the same position
one line up. If the previous line is shorter than the current line, the cursor
simply moves to the end of the previous line.

See Also: up;

backward-select; forward-select; down-select; word-forward-select; word-backward-
select; line-begin-select; line-end-select; screen-up-select; screen-down-select; buffer-
begin-select; buffer-end-select.

3.11 W-Z

3.11.1 word-backward
Default Bindings:

Keyboard - C-Left
Purpose: Moves the cursor backward by one word.

Usage: Self explanatory. If you are already at the beginning of a word, the
cursor moves to the first letter of the previous word. If you are in the middle or
at the end of a word, the cursor moves to the first letter of that word.

See Also: char-forward; char-backward; word-forward; tab-forward; line-begin;
line-end; up; down; screen-up; screen-down; buffer-begin; buffer-end.

3.11.2 word-backward-select
Default Bindings:

Keyboard - S-C-Left

Purpose: Highlights (selects) the text between the starting and ending posi-
tions during a word-backward move. The highlighted text is shown in reverse
video.



3.11. W-Z 97

See Also: word-backward; backward-select; forward-select; up-select; down-
select; word-forward-select; line-begin-select; line-end-select; screen-up-select;
screen-down-select; buffer-begin-select; buffer-end-select.

3.11.3 word-capitalize
Default Bindings:

Keyboard - M-c Right

Purpose: Capitalizes the next character to the right of the current cursor,
and moves the cursor position to the beginning of the next word.

Usage: No case change occurs for preselected text.

Examples: If your current cursor location is immediately to the left of the

“p” in the word description and you execute the word-capitalize function,

description will change to descriPtion.

See Also: word-lowcase; word-upcase.

3.11.4 word-delete-backward
Default Bindings:

Keyboard - C-BackSpace
Purpose: Deletes the previous word.

Usage: If the cursor is in between words (in whitespace), then the previous
word is deleted.

If the cursor is in the middle of a word, then the beginning of the word is
deleted to the cursor location.

If the cursor is at the beginning of a paragraph, then the last word of the
previous paragraph is deleted. Also in this case, if both paragraph have the
same environment, LyX will join the two paragraphs.

See Also: word-delete-forward.

3.11.5 word-delete-forward
Default Bindings:

Keyboard - C-Delete
M-d in emacs.bind
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Purpose: Deletes the next word.

Usage: If the cursor is in between words (in whitespace), then the next word
is deleted.

If the cursor is in the middle of a word, then the end of the word is deleted
to the cursor location.

If the cursor is at the end of a paragraph, one of two things can happen.
If the current and next paragraph have the same paragraph environment, LyX
merges the two paragraphs, but doesn’t delete any words. If the two paragraphs
have different environments, nothing happens. Note that this is different from
the behavior of word-delete-backward.

See Also: word-delete-backward.

3.11.6 word-forward
Default Bindings:

Keyboard - C-Right
Purpose: Moves the cursor forward by one word.

Usage: Unlike word-backward, this function always displays the same behav-
ior. It always moves the cursor to the beginning of the next word, no matter
where the starting cursor location may be.

See Also: char-forward; char-backward; word-forward; word-backward; tab-
forward; line-begin; line-end; up; down; screen-up; screen-down; buffer-begin;
buffer-end.

3.11.7 word-forward-select

Default Bindings:

Keyboard - S-C-Right

Purpose: Highlights (selects) the text between the starting and ending posi-
tions during a word-forward move. The highlighted text is shown in reverse
video.

See Also: word-forward;

backward-select; forward-select; up-select; down-select; word-backward-select;
line-begin-select; line-end-select; screen-up-select; screen-down-select; buffer-
begin-select; buffer-end-select.



3.11. W-Z 99

3.11.8 word-lowcase

Default Bindings:

Keyboard - M-c Down

Purpose: Forces a word to all lowercase, then moves the cursor to the start
of the next word.

Usage: Only the portion of the word to the right of the cursor is affected. No
case change occurs for preselected text.

Examples: If your current cursor location is immediately to the left of the
“p” in the word DESCRIPTION and you execute the word-lowcase function,
DESCRIPTION will change to DESCRIption.

See Also: word-capitalize; word-upcase.

3.11.9 word-upcase

Default Bindings:

Keyboard - M-c Up

Purpose: Forces a word to all uppercase, then moves the cursor to the start
of the next word.

Usage: Ounly the portion of the word to the right of the cursor is affected. No
case change occurs for preselected text.

Examples: If your current cursor location is immediately to the left of the “p”
in the word description and you execute the word-upcase function, description
will change to descriPTION.

See Also: word-capitalize; word-lowcase.
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Chapter 4

(eneral Information

Ed. Note: This is otherwise known as The Dreaded Miscellaneous! It’ll be a
pain to maintain, since I’ll probably be splitting it every few months! -jw

Reserved for Future Use.
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