The IyX Tutorial

by the LyX Team!

January 20, 2008

'If you have comments or error corrections, please send them to the IyX Documenta-
tion mailing list, lyx—docs@lists.lyx.org.



i1



Contents

1 Introduction
1.1 WelcometoLyX! . . ... ... ... ... L.
1.2 What the Tutorial is and whatitisn’t . . . . . . .. .. ... ...
1.2.1  Getting the most out of the Tutorial . . . ... ... ...
1.22 Whatyouwon’tfind . . ... ... ... ... .....

2 Getting started with LyX
2.1 Your first LyX document . . . .. ... ... 0oL
2.1.1 Typing, Viewing, and Exporting . . . . . ... ... ...
2.1.2  Simple Operations . . . . .. . ... ... ........
2.1.3  WYSIWYM: Whitespacein Ly X . . ... ... ... ..
2.2 Environments . . . . . . .. ... e
2.2.1 Sections and Subsections . . . . . ... ... .. ... ..
222 Listsandsublists . . . ... ... ... ... ... ....
2.2.3  Other environments: Verses, Quotations, and more . . . .

3  Writing Documents
3.1 DocumentClasses . . . . . . ... ... ... ... ...
3.2 Templates: Writingaletter . . . . . . ... ... .........
33 DocumentTitles . . . . . . ... ... .. ... .. ........
3.4 Labels and Cross-References . . . . . ... ... ... ......
3.5 Footnotes and MarginNotes . . . . . ... ... ... ......
3.6 Bibliographies . . . . . . . ... ... o
377 TableofContents . . . . ... ... ... ... ... .......

4 Using Math
41 MathMode ... ... ... .. .. .. ...
4.2 Navigatingan Equation . . . . .. ... ... ... ... ...,

1l

11
11
12
13
14
16
17
17



v

CONTENTS

4.3 Exponents and Indices . . . .. ... ... ... ... ..., 21
44 TheMathToolbar . . . . ... ... ... ... ... ....... 21
44.1 Greekandsymbols . . . .. ... ... ... ... ..., 21

4.4.2 Square roots, accents, and delimiters . . . . . . . ... .. 22

443 Fractions . . . .. ... .. ... 22

444 TgX mode: Limits, log, sinand others . . . . . ... ... 23

445 Matrices. . . . ... 23

446 Displaymode . . . ... ... ... ... ... .. ... 24

4.5 MoreMath Stuff . . .. ... ... ... ... . ... 25
Miscellaneous 27
5.1 Other major LyX Features . . . . ... ... ... ........ 27
52 IyXforIAIEX Users . . . .. ... ... ... L 28
521 TeXMode . ... ... .. ... 28

5.2.2  Importing I&TEX Documents — tex21lyx . . . . . . .. 29

5.2.3 Converting LyX Documents to IXIEX . . . . . . . . . .. 29

524 I&EXPreamble . . . ... ... oL 30

525 BibIEX . . ..o 30



Chapter 1

Introduction

1.1 Welcome to LyX!

This file is designed for all of you who have never heard of IXTEX, or don’t know
it very well. Now, don’t panic - you won’t need to learn I&IEX to use LyX. That
1s, after all, the whole point of LyX: to provide an almost-WYSIWYG interface
to I&TEX. There are some things you will need to learn, however, in order to use
LyX effectively.

Some of you probably found your way to this document because you tried to
put two spaces after a “.” or tried to put 3 blank lines between paragraphs. You
found out you couldn’t and in fact, you’ll find out that most of the little tricks
you’re accustomed to use in other word processors won’t work in LyX. That’s
because most word processors you’ve used before allow you to manually enter all
spacings, font changes, and so on. So you end up not only writing a document
but typesetting it, too. LyX does the typesetting for you, in a consistent fashion,
letting you focus on the important things, like the content of your writing.

So read on to learn more about LyX. Reading this tutorial is definitely worth
the time.

1.2 What the Tutorial is and what it isn’t

Before we get started with this section, we want to make a quick note of some-
thing. The Tutorial uses the notation outlined in the Introduction manual. If you
came to this manual first, please read the Introduction before you continue with
the Tutorial.
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Now that you know which fonts mean what, we want to talk a bit about what
this Tutorial is for.

1.2.1 Getting the most out of the Tutorial

This tutorial consists of examples and exercises. To get the most out of this doc-
ument, you should read through the document, typing all the little things we’re
telling you to type and trying out all of the exercises to see if you get them right.
For convenience, you might want to print out the PDF version of this document.

If you are familiar with IATEX, you’ll probably be able to read the Tutorial
somewhat faster, since many LyX ideas are just I&IEX ideas in disguise. However,
LyX have features you’ll want to learn about. Even if you don’t feel like reading
the rest of the Tutorial, you should definitely check out Section 5.2, which is
specifically written for experienced IATEX users.

1.2.2 What you won’t find

e Detailed explanations of all of LyX’s features.

Look in the User’s Guide when you need this.

e Detailed explanations of IATEX.

Unnecessary. If you want to learn some of the neat tricks you can do with
IATEX in LyX, you can have a look at the Embedded Objects manual.

It’s time to move onwards, time for your first document . ..



Chapter 2

Getting started with LyX

2.1 Your first LyX document

OK. You're ready to start writing. Before you do, there are a few things we need
to mention, which will hopefully make the Tutorial more instructive and useful.

Because there are informations we can’t give you in the Tutorial, the first thing
that you need to do is find the other help files. This is very simple: Start up LyX,
Choose the User’s Guide from the Help menu. You may want to load the Tutorial
as well (if you’re not reading it within LyX already). This way, you can read
them while you’re writing your own file.! Note that once you’ve got more than
one document open, you can use the View menu or the document tabs to switch
between them.

In this Tutorial, we’re going to assume that you have a fully working version
of LyX, as well as a IAIgX-distribution, a DVI-, and a PDF-viewer. This should be
the case on all major Linux- and BSD-distribution, as well as on Windows, where
this is setup by the Ly X installer.

Finally, we’ve written a file to let you practice your LyX skills on, it’s called
example_raw.lyx. Imagine that it was typed by someone who didn’t know
about any of LyX’s great features. As you learn new LyX functions, we’ll sug-
gest that you fix those parts of example_raw.lyx. It also contains “subtle”
hints about how to fix thingsz. If you want to cheat, or check what you’ve done,
there’s also a file called example_lyxified.lyx which contains the same
text written and typeset by a LyX master.

I'They can also serve as good examples of how to use the many features of LyX.
2The hints are located in yellow “Notes”. Access the text in a note by clicking on it.

3
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The example files can be found in the examples directory of LyX’s installa-
tion folder. Open the raw document, and use File>Save As to save a copy in your
own directory for you to work on. As you fix parts of the raw document, check to
see how those changes affect the DVI output.

By the way, the examples directory contains lots of other examples files.
They will show you how to do various fancy things with LyX. After you read the
Tutorial, or when you’re confused about how to do something fancy in Ly X, take
a look at these files.

2.1.1 Typing, Viewing, and Exporting

e Open a new file with File>New

e Type a sentence like: This is my first LyX document!

Save your document with File>Save As.

Run I£TEX to create a DVI file, with Viewr>DVI or the toolbar button .
LyX will open a DVI-viewer program displaying your document looking
like when printed.>

Export the ready to print document with File > Export to a format you want.

Congratulations! You’ve written your first LyX document. All of the rest is just
details, which is covered in the other manuals.

2.1.2 Simple Operations

LyX can of course do most of the things you’re used to do with a word processor.
It will word-wrap and indent paragraphs automatically. Here’s a quick description
of how to do some simple actions.

Undo LyX has multiple levels of undo, which means you can undo everything
you’ve done since your current editing session started, by selecting Edit>

3You can save time by leaving the DVI-viewer running in the background. Then, you can

use View> Update>DVI or the toolbar button @ and just click on the DVI-viewer window (or
unminimize it) after I&IEX finishes running.
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Undo (toolbar button [@) over and over again. If you undo too much, just
select Edit> Redo (toolbar button @) to get it back.

Currently, undo is limited to 100 steps. Undo also doesn’t work for every-
thing; for instance, not for changes to the document layout what is really a
LyX bug.

Cut/Paste/Copy Use Edit> Cut (toolbar button %) Edit> Copy (toolbar button

.) and Edit> Paste (toolbar button -) to cut, copy, and paste. Or au-
tomatically paste selected text (including selections from other programs)
with the middle mouse button.

Find/Replace Use Edit>Find & Replace (toolbar button -G}Q) to search. In the
dialog, search with the Find Next button, and use the Replace button to
replace a word you’ve found®. If you like, you can specify whether to make
the search case-sensitive, or to search for only complete words; you can also
search backwards through the document.

Character Formatting You can emphasize text (which will by default print char-
acters in italics), set it in bold face, or in NOUN STYLE (usually small caps,
used for people’s names) from the toggle buttons in the Edit>Text Style

dialog (toolbar button Hb).

Toolbar There are buttons on the toolbar (just below the menus) which allow you
to do some of the more popular functions, such as Paste and Print.

Of course, you haven’t yet written enough to make most of these functions useful.
As you write more, though, try undoing, pasting, etc.

2.1.3 WYSIWYM: Whitespace in LyX

One of the hardest things for new users to get used to is the way that LyX handles
whitespace. As many times as you hit Return, you’ll only get one blank line. As
many times as you hit Space, you’ll only get one space. On a blank line, LyX

“4Close the window when you’re done or leave it open if you find it more convenient. Most
dialog boxes in LyX can operate like this. Just be sure you have the right window focus when
you’re trying to type in the main LyX window or a LyX dialog.
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won’t let you type even one space. The Tab key won’t move you forward one tab
stop; in fact there are no tab stops! There’s no ruler at the top of the page to let
you set tabs or margins, either.

Many commercial word processors are based on the WYSIWYG principle:
“What You See Is What You Get.” LyX, on the other hand, is based on the princi-
ple that “What You See Is What You Mean.” You type what you mean, and LyX
will take care of typesetting it for you, so that the output looks nice. A Return
grammatically separates paragraphs, and a Space grammatically separates words,
so there is no reason to have several of them in a row; a Tab has no grammati-
cal function at all, so LyX does not support it. Using LyX, you’ll spend more of
your time worrying about the content of your document, and less time worrying
about the format. See the Introduction for more information on the WYSIWYM
concept.

LyX does have (many) ways to fine-tune the formatting of your document.
After all, LyX might not typeset exactly what you mean. The User’s Guide has
information about all that. It includes HFills and vertical space — which are more
powerful and versatile than multiple spaces or blank lines — and ways to change
font sizes, character styles, and paragraph alignments by hand. The idea, though,
is that you can write your whole document, focusing on content, and just worry
about that fine-tuning at the end. With standard word processors, you’ll be dis-
tracted by document formatting throughout the writing process.

2.2 Environments

Different parts of a document have different purposes; we call these parts envi-
ronments. Most of a document is made up of regular text. Section titles (chapter,
subsection, etc.) let the reader know that a new topic or subtopic will be discussed.
Certain types of documents have special environments. A journal article will have
an abstract and a title. A letter will have neither of these, but will probably have
an environment that gives the writer’s address.

Environments are a major part of the “What You See Is What You Mean” phi-
losophy of LyX. A given environment may require a certain font style, font size,
indenting, line spacing, and more. This problem is aggravated, because the exact
formatting for a given environment may change: one journal may use boldface,
18 point, centered type for section titles while another uses italicized, 15 point,
left justified type; different languages may have different standards for indenting;
and bibliography formats can vary widely. LyX lets you avoid learning all the
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different formatting styles.
The Environment choice box is located on the left end of the toolbar and looks

. . Standard . g . . )
like this: = . It indicates which environment you’re currently

writing in. While you were writing your first document, it said “Standard,” which
is the default environment for text. Now you will put a number of environments
in your new document so that you can see how they work.

2.2.1 Sections and Subsections

Type the word Int roduct ion on the first line of your LyX file, and select Sec-
tion in the Environment box.> Be sure to use Section and not Section*, which will
be covered below. LyX numbers the section “1” and typesets the section heading
(title) in a larger font. Now hit Return. Note that the Environment box changes
from “Section” back to “Standard”. Section headings, like most environments,
are assumed to end when you type Return. Type the document introduction:

This is an introduction to my first LyX document.

Hit Return again, and select Section from the Environment box again. LyX writes
a “2” and waits for you to type a title. Type “More Stuff”, and you’ll see that
LyX again sets it as a section title.

It gets better. Go to the end of Section 1 again (after “my first LyX docu-
ment”) and hit Return again, and select Section from the Environment box again.
Again, LyX writes “2” and waits for you to type a title. Type About This
Document. Section “More Stuff”, which used to be Section 2, has been auto-
matically renumbered to Section 3! In true WYSIWYM fashion, you just need to
identify the text that makes up the section titles, and LyX takes care of numbering
the sections and typesetting them.

Hit Return to get back to the Standard environment, and type the following
five lines:

Sections and subsections are described below.
Section Description

>You don’t have to select the line. If nothing is selected, LyX changes the paragraph you are
currently in to the selected environment. Alternatively, you can change several paragraphs to a
different environment by selecting them before picking an environment.
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Sections are bigger than subsections.
Subsection description
Subsections are smaller than sections.

Click on the second line and select Subsection from the Environment box. LyX
numbers the subsection “2.1”, and typesets it in a font which is bigger than reg-
ular text but smaller than the section title. Change the fourth line Subsection
environment as well. As you probably expected, LyX automatically numbered the
section “2.2”. If you put yet another section before Section 2, Section 2 will be
renumbered as Section 3, and the subsections will be renumbered to “3.1” and
“3.2%.

Further levels of sectioning include Subsubsection, Paragraph, and Subpara-
graph. We’ll let you play with these on your own. You may notice that paragraph
and subparagraph headings are not numbered by default, and that subparagraphs
are indented; see the User’s Guide for an explanation and how to change this.
Chapter headings are actually the highest level of sectioning, above Sections, but
you’re only allowed to use them in certain types (text classes) of LyX documents
(see Section 3.1).

Finally, you may want to have sections or subsections that are not numbered.
There are environments for this as well. If you change one of your section head-
ings to the Section* environment (you may have to scroll down in the Environment
box to find it), LyX will use the same font size for the heading as it uses for a reg-
ular section, but it won’t number that section. There are corresponding “starred”
heading environments for Subsection and Subsubsection. Try changing some of
your sections or subsections to the starred environments, and note how the other
sections’ numbers are updated.

Exercise: Fix the section and subsection headings in example_raw.lyx.

2.2.2 Lists and sublists

LyX has several different environments for typesetting lists. The various list en-
vironments free you from hitting Tab a million times when writing an outline, or
from renumbering a whole list when you want to add a point in the middle of the
list. Different types of documents logically require different list environments:

e A slide presentation might use the Itemize environment’s bulleted lists to
describe different points.



2.2. ENVIRONMENTS 9

e An outline would use the Enumerate environment’s numbered lists (and
lettered sublists).

e A document describing several software packages could use the Description
environment, where each item in the list begins with a bold-faced word.

e The List environment — not found in IATEX — is a slightly different form
of the Description environment.

Let’s write a list of reasons why LyX is better than other word processors. Some-
where in your document, type:
LyX is better than other word processors because:
and hit Return. Now select ltemize from the Environment box. LyX writes a
“bullet” on the line. Type in your reasons:

Typesetting is done for you.
Math is WYSIWYG
Lists are very easy to create!

List environments, unlike headings, do not end when you type Return. Instead,
LyX assumes you’re going on to the next item in the list. The above will therefore
result in a three-item list. If you want more than one paragraph within one list
item, one way is to use the Protected Break, which you get by typing C-Return.
In order to get out of the list, you need to reselect the Standard environment (or
just use the keybinding, M-p s).

You’ve got a beautiful itemized list. You might want to run I&TEX to see how
the list looks when printed out. But what if you wanted to number the reasons?
Well, just select the whole list® and choose Enumerate from the Environment
box. Pow! As we mentioned, if you add or delete a list item, LyX will fix the
numbering.

While the list is still selected, you can change to the other two list environ-
ments, Description and List, in order to see what they look like. For those two
environments, each list item is made up of a term, which is the item’s first word,
followed by a definition, which is the rest of the paragraph (until you hit Return.)

®LyX won’t let you select the first bullet unless you also select the paragraph before the list,
which you probably don’t want to do. Similarly, you can’t select the actual number in a numbered
section title. This is on purpose because the bullet or number depends on the document settings or
text position, respectively.
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The term is either typeset in boldface (Description) or separated by a “Tab”’ (List)
from the rest of the paragraph. If you want to have more than one word in the
definition, then separate the words with Protected Blanks.

Exercise: Typeset the list in example_raw.lyx

You can nest lists within each other in all sorts of interesting ways. An ob-
vious example would be writing outlines. Numbered and bulleted lists will have
different numbering and bulleting schemes for sublists. See the User’s Guide for
details on the different sorts of lists and for examples of nestings.

2.2.3 Other environments: Verses, Quotations, and more

There are two environments for setting quotations apart from surrounding text:
Quote for short quotes and Quotation for longer ones. Computer code (the LyX-
Code environment 8) is written in a t ypewriter font; this environment is the
only place in LyX where you’re allowed to use multiple spaces to allow code in-
denting. You can even write poetry using the Verse style, using Return to separate
stanzas, and C-Return to separate lines within a stanza. See the User’s Guide for
more complete descriptions of all of the available LyX environments.
Exercise: Correctly typeset the Quote, LyX-Code, and Verse in

example_raw.lyx

"But a typesetter’s tab, which will change to fit the size of the largest term, not a pathetic, rigid,
unchangeable typewriter Tab.
8used in this Tutorial for the long typing examples
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Writing Documents

The previous chapter hopefully allowed you to get used to writing in LyX. It
introduced you to the basic editing operations in LyX, as well as the powerful
method of writing with environments. Most people who use LyX, though, will
want to write documents: papers, articles, books, manuals, or letters. This chapter
is meant to take you from simply writing text with LyX to writing a complete
document. It will introduce you to text classes, which allow you to write different
sorts of documents. It will then describe many of the additions that turn text into
a document, such as titles, footnotes, cross references, bibliographies, and tables
of contents.

3.1 Document Classes

Different sorts of documents should be typeset differently. For example, books
are generally printed double-sided, while articles are single-sided. In addition,
many documents contain special environments: letters contain some environments
— such as the sender’s address and the signature — which do not make sense
in a book or article. The LyX document class' takes care of these large scale
differences between different sorts of documents. This Tutorial, for example, was
written in the Book document class. Document classes are another major part of
the WYSIWYM philosophy; they tell LyX how to typeset the document, so you
don’t need to know how.

Your document is probably being written in the Article document class.> Try

Ifor IATEX users: this is equivalent to the ISTEX document class
That’s usually the default document class

11
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changing to other document classes (using the Document> Settings dialog) to see
how they are typeset differently. If you change your document to the Book docu-
ment class and look at the Environment box, you’ll see that most of the allowed
environments are the same. However, you can now use the Chapter environment.
If you are ever unsure about which environments you can use in a given document
class, just consult the Environment box.

Font sizes, one- or two-column printing, and page headings are just some of
the ways journals’ typesettings differ from one another. As the Computer Age
continues to mature, journals have begun accepting electronic submissions, creat-
ing IATEX “style files” so that authors can submit correctly typeset articles. LyX
is set up to support this as well. For example, LyX supports typesetting (and
extra environments) for the American Mathematics Society journals using the Ar-
ticle (AMS) document class.

Here is a very quick reference to some of the document classes. See the Spe-
cial Document Classes section of the Extended Features manual for many more
details.

| Name | Notes |
article one-sided, no chapters
article (AMS) | layout & environments for American Math Society
report longer than article, two-sided
book report + front and back matter
presentation transparencies
letter lots of extra environments for address, signature. . .

3.2 Templates: Writing a Letter

One way to write a letter would be to open a new file, and choose a Letter class
in the Document > Settings dialog. While this is the most obvious way to write a
letter, it seems like extra work. Every time you write a business letter, you want
to have your address, the address you’re sending to, a body, a signature, etc. LyX
therefore has a template for letters, which contains a sample letter; once you have
a template, you can just replace a couple parts of the letter with your text each
time you write a letter.

Open a new file with File>New from Template. Select letter.lyx as the
template. Save and print the file to see how the various environments are typeset.

When you look at the Environment box, you’ll see several environments, like
the My Address environment, which don’t even exist in most other document
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classes. Others, like Quote and Description, are familiar. You can play around
for a while to figure out how the various environments work. You’ll notice for
example that the Signature environment has the word “Signature:* in red before
the actual text of the signature. This word doesn’t show up in the actual letter,
as you’ll see if you view/export the file. It’s just there to let you know where the
signature goes. Also, note that it doesn’t matter where in the file the Signature line
is placed. Remember, LyX is WYSIWYM; you can put the Signature environment
anywhere you want, but LyX knows that in the printout, the signature should be
at the end.

A template is just a regular LyX file. This means you can fill in your address
and signature and save the file as a new template. From now on, any time you
want to write a letter, you can use the new template to save time. We don’t have
to suggest an actual “exercise” here; just write a letter to someone!

Templates can be a huge time-saver, and we urge you to use them whenever
possible. In addition, they can help a person learn how to use some of the fancier
document classes. Finally, they may be useful for a person who is configuring
LyX for a bunch of less computer-aware users. When they’re first learning LyX, it
will be much less intimidating if they have a letter template customized for their
company, for example.

3.3 Document Titles

LyX (like I&TEX) considers the title — which may contain the actual title, the
author, the date, and even an abstract of a paper — to be a separate part of the
document.

Go back to your LyX document and make sure it’s using the Article document
class.* Type a title on the first line, and change the line to the Title environment.
On the next line, type your name and change it to the Author environment. On
the next line, write the date in the Date environment. Type a paragraph or two
summarizing your document using the Abstract environment. Notice how the title

30ne warning, if you’re writing from a template. If you erase all of the text in an environment
— for example, if you erase the whole My Address field so that you can replace it with your own
— and then you move the cursor without writing any text, the environment may disappear. This
is because most environments cannot exist without any text in them. Just reselect the environment
from the Environment box to get it back.

“You should not be using the letter any more, since the Letter document class doesn’t allow
titles.
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is presented when it’s printed out. If you changed the document format to Book,
you’ll get a separate title page, like the first page of this tutorial.
Exercise: Fix the title, date, and author in example_raw.lyx

3.4 Labels and Cross-References

You can label section headings, list items, formulas, footnotes, and floats in your
document. Once you do so, you can refer to this section in other parts of the
document, using cross-references. You can refer either to the section’s number,
or to the page that the section appears on. As with section numbering, LyX also
takes care about cross-reference numbering for you. Automatic labels and cross-
references are one of the best advantages of LyX (and IATEX) over conventional
word processors.

Your first label

Go to our second section, whose title is “About This Document”. Click at the end

of the section title line, and select Insert> Label or the toolbar button @ A dialog
asks you for a label name, and gives you a suggestion. When you click on OK, the
label name will be placed in a box next to the section title.

By the way, you could have put the label right anywhere within the section as
well; section references will refer to the last section or subsection whose heading
comes before the label. However, putting it on the same line as the section title
(or, perhaps, on the first line of the section’s text) ensures that page references will
reference the beginning of the section.

So far you haven’t done anything — the DVI output will look exactly the same,
since labels don’t show up in the printed document. However, now that you have
added a label, you can refer to that label with cross-references. We’ll do that next.

Your first cross-reference

Place the cursor somewhere in Section 2 of your document. Type

If you want to know more about this document, then see
Section , which can be found on page

SFloats are explained in the User’s Guide and the Embedded Objects manual.
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Now — with the cursor after the word “section” — choose Insert> Cross Refer-

ence or the toolbar button tﬁl The Cross-reference dialog pops up. It shows a
list of the possible labels you can reference. At the moment, there should be only
one, “‘sec:About-This-Document”. Select it (it may be selected by default), and
click Apply. Now put the cursor after the word “page”, and change the reference
format to use the page number then click Apply. (To be really correct, you should
put a Protected Blank in between the word “Section” and the reference. Same for
the page reference.)

LyX puts the references in a box right where the cursor was. In the printed
document, this reference marker will be replaced with either the page or section
number (depending on what you selected in the Cross-reference dialog). View
your document as DVI, and you’ll see that on the last page we refer to “Section 2”
and “Page 17 (or whatever page Section 2’s title is on).

Conveniently, a cross-reference acts as a hyperlink when you are editing a
document in LyX; clicking on it will pop up the Cross-Reference dialog, clicking
Go to Label will move the cursor to the referenced label.

More fun with labels

We told you that LyX takes care about numbering cross-references; now you can
test that. Add a new section before Section 2. Update the DVI view, and — voila!
— the section cross reference changed to “3”! Change the section “About this
Document” to a subsection, and the cross-reference will reference Subsection 2.1
instead of Section 3. The page reference won’t change unless you add a whole
page of text before the label, of course.

If you want some more practice with labels, then try putting a new label where
your first cross-reference was, and refer to that label from elsewhere in the docu-
ment. If you’ll be inserting cross-references often, it may be convenient to leave
the Cross-reference dialog open.

If you want to make sure that the cross-referencing gets the pages right even
for larger documents, Copy a couple pages of text from the User’s Guide to the
clipboard, and Paste the stolen text into your document.®

Exercise: Fix the references in example_raw.lyx

By the way, copying a chapter title may cause an error, because chapters aren’t allowed in the
article class, see section 3.1. If this happens, just delete the chapter title.
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3.5 Footnotes and Margin Notes

Footnotes can be added using the toolbar button E or the menu Insert> Footnote.
Click at the end of the word “LyX” somewhere in your document and click the

E button. A footnote box appears where you can enter the text of the footnote.
LyX should place the cursor at the beginning of the footnote box. Type

LyX is a typesetting word processor.

Now click on the button labelled “foot”. The footnote box is closed, leaving the
button showing where the footnote marker will be in the printed text; this is called
“folding” the footnote. You can unfold the footnote at any time — and re-edit its
text, if you want — by clicking again on the “foot” button.

You may wonder why the footnote button is a word instead of a number. The
answer is that LyX takes care about the footnote numbering for you in the printed
text. You can see this yourself by looking at the DVI file (or printout). If you
add other footnotes, LyX will renumber the footnotes. Since LyX (well, ISTEX,
actually) takes care of the footnote numbering, there’s really no need to put the
numbers in the LyX file.

A footnote can be cut and pasted like normal text. Go ahead; try it! All you
need to do is select the footnote button’ and Cut and Paste it. In addition, you can

change regular text to a footnote, by selecting it and hitting the I_ button; change
a footnote to regular text by hitting the Backspace key when the cursor is in the
first position of a footnote, or by hitting the Delete key when the cursor is in the
very last position of the footnote, respectively.

Margin notes can be added using the menu Insert>Marginal Note or the tool-

bar button §| Margin notes are like footnotes, except that:
e the on-screen boxes say “margin” instead of “foot”
e the notes will be placed in the margin, instead of below the text
e margin notes are not numbered

Change your LyX footnote back to text, then select and change it to a margin note.
Run IATEX again to see what the margin note looks like.
Exercise: Fix the footnote in example_raw.lyx

Tt may be easier to select it using the keyboard. You might accidentally open the footnote if
you're trying to select the marker itself with the mouse.
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3.6 Bibliographies

Bibliographies (at least in the exact sciences) are similar to cross references. The
bibliography contains a list of references at the end of the document, and they can
be referenced from within the document. Like section titles, LyX and I&TEX make
your job easier by automatically numbering the bibliography items and changing
citations when the item numbers change.

Go to the end of the document and switch to the Bibliography environment.
Now, each paragraph you type will be areference. Type “The Lyx Tutorial,
by the LyX Documentation Team” as your first reference. Note that
LyX automatically puts a number in a box before each reference. Click on the
boxed reference number, and the Bibliography item dialog box appears. The Key
is to refer to this reference within the LyX document, the Label appears in output.
When no Label is set (default), you will see the number of the bibliography in the
output. Change now the Key field to “lyxtutorial” to make it easy to remember.

Now pick somewhere in your document that you would like to insert a ref-

erence. Do so with Insert> Citation or the toolbar button ‘ﬁ A Citation dialog
appears. The right panel in this dialog lists all the bibliography entries, and this
field allows you to choose which bibliography item you want to cite. Select “lyx-
tutorial” (right now, that’s the only item in the bibliography), then use the Add
button in the center to insert it. (You can have multiple citations in the same place
by transferring a number of keys this way.) Now view your file as DVI, and you’ll
see that the citation appears in brackets in the text, referring to the bibliography at
the end of the document.

The Text after field in the Citation dialog will put a remark (such as a reference
to a page or chapter within the referenced book or article) in the brackets after
the reference. If you want the references to have labels instead of numbers in
the printed output (for example, some journals would use “[Smi95]” to refer to
a paper written by Smith in 1995), use the Label field in the Bibliography item
dialog. As usual, see the User’s Guide for details.

Exercise: Fix the bibliography and citation in example_raw.lyx

3.7 Table of Contents

You may want to put a table of contents at the beginning of your document. LyX
makes this very easy to do. Just hit Return after your document title and before
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your first section title and choose Insert>List / TOC> Table of Contents. The
words “Table of Contents” will appear in a button on the first line of the document.

This may not appear to be very useful. However, if you look at your DVI file,
you will see that a table of contents has been generated, listing the various sections
and subsections in your document. As usual, if you reorder sections or create new
ones, you will see those changes in the DVI file when you update it.

The table of contents is not printed in the on-screen version of the document to
keep the overview in your file. But you can display the table of contents in a sep-
arate window by clicking on the table of contents button, or by using Document >

Outline or the toolbar button @ This menu will work even if you don’t have a
table of contents inset in your document. This is a very useful tool where you can
move around your document parts. Clicking on a (sub)section title in the Outline
window will highlight that line and move the display (in the LyX editing window)
to that place in the document. You can also use the arrow keys to move up and
down in the table of contents. You may therefore find it convenient to leave this
window open throughout editing sessions. You can get similar functionality from
the Navigate menu, though, where the table of contents appears automatically.

To get rid of the Table of Contents, you can delete the table of contents button
just like any other text.

Exercise: Fix the table of contents in example_raw.lyx



Chapter 4
Using Math

I&TEX is used by many scientists because it outputs great looking equations, avoid-
ing the control characters used by word processors and their equation editors.
Many of these scientists are frustrated, however, because writing equations in
IATEX 1s more like programming than writing. Happily, LyX has WYSIWYM sup-
port for equations. If you are used to I&TEX, you’ll find that all of the usual IATEX
math commands can be typed in normally, but they will show up ina WYSIWYM
fashion. If, on the other hand, you’ve never written in IX[EX, then the Math Panel
will allow you to write professional-looking math quickly and easily.

4.1 Math Mode

Somewhere in your LyX document, type:

I like what Einstein said, E=mc"2, because it’s so

Now, that equation doesn’t look very good in LyX and in the output; there’s no
space between the letters and the equals sign, and you’d like to write an actual
superscript for the “2”. That bad typesetting happened because we didn’t tell LyX
that we were writing a mathematical expression, so it typeset the equation like
regular old text.

Instead, we create a formula that will get typeset properly. In order to cre-
a+d
ate a formula, just click the toolbar button 7z or use the menu Insert>Math>

Inline Formula. LyX will insert a little blue square, which is an empty math for-
mula. Now just type E=mc” 2 again. The expression is typed in blue, and the blue

19

simple.
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square disappears as soon as the formula is not empty. Now type Esc to leave
the equation The purple markers disappear, leaving the cursor to the right of the
expression, and now if you type something, it will be regular text.

Run IATEX and look at the output. Notice that the expression was typeset
nicely, with spaces between the letters and the equals sign, and a superscript “2”.
Letters in math mode are assumed to be variables, and come out in italics. Num-
bers are just numbers.

This math editor is another example of the WYSIWYM philosophy. In I&TEX,
you write a mathematical expression using text and commands like \ sgrt; this
can be frustrating, because you can’t see what an expression looks like until you
IATEX the file, and may have to spend time to find e. g. missing brackets. LyX
doesn’t attempt to get the expression to look perfect (WYSIWYG), but it gives
you an extremely good idea of what the expression will look like. IATEX then
takes care of the professional typesetting.

4.2 Navigating an Equation

Now let’s change E = mc? to E = 1+mc?. Use the arrow keys to move the cursor
into the expression. Note that when you enter the expression, the purple markers
appear to let you know you’re editing math. Now you can use Left and Right to
move the cursor past the equals sign, and just type “I1+”. Again, you can use the
arrow keys or Esc to leave the formula.

Other than the special keys described below, typing in math mode is like edit-
ing regular text. Use Delete (or Backspace) to delete things. Select text either
with the arrow keys or with the mouse. Edit>Undo works in math mode as well
as cut and paste. One thing to be careful of: If you are left or right outside a
formula and you press Delete or Backspace, respectively, you delete the whole
formula. Luckily, you can just use Undo to get it back.

What if you want to change E = mc? to E = mc*>> + 1? Again, you can use
the mouse to click in the right place. However, you can also use the arrow keys.
If the cursor is just after the “c” but before the “2”, then press Up and the cursor
1s moved to the level of the superscript, just before the “2”. Add the “.5”. Now,
hitting Down will move the cursor back to the regular level. When you hit Space
instead of Down, the cursor will be placed affer the superscript (so that you can
then type the “+17).
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4.3 Exponents and Indices

An exponent can be entered from the Math Toolbar (see below), but it’s actually
simpler just to type the caret key, “*”. LyX will place another blue rectangle in the
superscript, so that whatever you write next will be superscripted, and in a smaller
font size. Everything you type until you hit a Space (or Esc to exit the formula
entirely) will be in the superscript.

Writing a subscript (index) is just as easy — start one by typing the underscore
key, “_*“. You can subscript and superscript both subscripts and superscripts like
this: A, 52 + caott,

Exercise: Put equation 1 of example_raw.1lyx into math mode.

4.4 The Math Toolbar

The Math Toolbar is a convenient way to enter symbols or to perform compli-
cated formula operations. Many of these operations can be accomplished from
the keyboard or the Edit>Math or Insert>Math menus. However, we’re going to
concentrate on using the Math Toolbars, just to let you know what’s out there; you
can learn keyboard shortcuts later, from other manuals.

The math toolbar is shown when the cursor is in a formula and can also be
turned on manually in the menu View > Toolbars. When you click there on “Math”
the toolbar will be shown permanently at the bottom; this state is visualized in the
Toolbars menu with a checkmark. When you click in this state again on “Math”
in the Toolbars menu, the math toolbar is only shown when the cursor is within a
formula; this state is visualized by the renaming of the menu entry from “Math”
to “Math (auto)”.

4.4.1 Greek and symbols

The Math Toolbar which allow you to choose from a large array of symbols used
in math: various arrows, relations, operators, and sums and integrals. Note that
subscripting and superscripting allow you to put lower and upper limits on sums
and integrals.

“Nothing you can do that can’t be done. .. All you need is ©.”
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4.4.2 Square roots, accents, and delimiters

To type a square root, just click on the button ¥vO. The square root appears, and the
cursor is in a new insertion point inside the square root. You can type variables,
numbers, other square roots, fractions, whatever you want. LyX will automatically
resize the square root to fit what’s inside.

Accenting a character (V') or group of characters (M) is done the same

way. Decorations are available from the toolbar via the button :.... Click on a
decoration, and LyX will insert that decoration with an insertion point under (or
over) it. Just type what you want in the insertion point. There are two sets of
decorations: those that resize with the text you type, and those that have fixed
size, and are most appropriate for a single letter.

Delimiters such as parentheses, brackets, and braces work similarly, but are a

bit more complicated. Hit the delimiter button i to pop up the Delimiter dialog.
Your current selection of delimiters is displayed in a box. It’s a pair of parentheses
by default, but you can choose a pair of braces, a brace and a parenthesis, or
choose the empty square to have something like “a = (7 (the empty delimiter is
displayed as a broken line in LyX, but won’t show up in the output).

If you’re lazy, you can type actual parentheses in math mode, rather than using
the Delimiter dialog. However, those parentheses will be the same size as regular
text, which will look bad if you have a big fraction or matrix inside the parenthe-
ses. So better use in this case one of the three delimiter buttons that insert directly
e.g. a () pair.

You can also put delimiters or a square root sign or a decoration on already
existing formula parts. Select the portion of the formula that you want to adjust,
and then click on the button you want from the Math Toolbar. Try using this to
change Newton’s second law from scalar to vector form (f = ma to 7 =ma).
Once you’ve learned about matrices, this is how you’ll put parentheses or brackets
around them.

4.4.3 Fractions

a
To create a fraction, click on the fraction button b in the Math Toolbar. LyX
writes two insertion points in a fraction. As you would expect, you can use arrow
keys or the mouse to move around a fraction. Click on the top square and type
“1”. Now hit Down and type “2”. You’ve made a fraction! Of course you can type

anything within each of the two boxes: variables with exponents, square roots,



4.4. THE MATH TOOLBAR 23

other fractions, whatever.
Exercise: Put equation 2 of example_raw.1lyx into math mode.

4.4.4 TgX mode: Limits, log, sin and others

Because letters in math mode are considered to be variables, if you type “sin” in
math mode, LyX thinks you are typing the product of the three variables s, i, and
n. The three letters will be typeset in italics, when what you really wanted was
the word “sin” typeset in Roman. In addition, LyX won’t put a space between the
word “sin” and the “x” (pressing Space will exit the formula). So how do you get
“sin(x)” instead of “sin(x)”?

Click on the Math Toolbar button tan and then on “sin” in the appearing func-
tion list. The word “sin” is displayed in LyX in black, and set in upright roman
type. The whole word is treated as one symbol, so if you type Backspace, it will
delete the whole word. Now type “(x)”, which will be written in blue italics, like
you expect in a formula. In the output, the expression will be correctly typeset.
Try it out.

The function list include other trigonometric functions and their inverses, hy-
perbolic functions, logarithms, limits, and quite a few others. These functions can
take subscripts and superscripts, important for typing “cos? 8” or “lim,, _..”.

Exercise: Put equation 3 of example_raw. lyx into math mode.

4.4.5 Matrices

Click on the matrix button E& in the Math Toolbar. The appearing dialog allows
you to choose how many rows and columns you want in your matrix. Choose 2
rows and 3 columns and hit OK. LyX prints 6 insertion points in a 2 X 3 matrix. As
usual, you can put any sort of formula expression (a square root, another matrix,
etc.) in each insertion point. You can also leave some of the insertion points empty
if you want.

Tab can be used to move horizontally between the columns of a matrix. Alter-
natively, you can use the arrow keys to move around - hitting Right at the end of
one box will move to the next box, Down will move to the next row, etc.

If you need to change the number of rows and columns, use the menu Edit>

- o Ll
Math > Rows & Columns or the math toolbar buttons 5 E!, ﬁﬁ, ¥,

See the User’s Guide for information on how to change the horizontal align-
ment of each column, and how to change the vertical position of the whole matrix.
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Note that if you want to write a table containing text, you should use LyX’s won-
derful table support, rather than trying to write text in a matrix.

4.4.6 Display mode

All of the expressions we have written so far have been on the same line as the
text that came before and after them, otherwise known as inline expressions. This
is fine for short, simple expressions, but if you want to write larger ones, or if you
want your expressions to stand out from the text, you need to write them in display
mode. In addition, only displayed expressions can be labeled and numbered (see
the User’s Guide), and multi-line equations must be in display mode.

[=]

Click on the display button = in the Math Toolbar, which represents a couple
lines of text before and after a centered blue box. LyX inserts a formula, but the
insertion point is on a new line, and it’s centered within that line. Now type an
expression and run I&TEX to see how it looks. The display button is actually a
toggle; use it now to change a couple of your expressions to display mode and
back.

Display mode has a couple differences from inline mode:

e The default font is larger for a few symbols, like Y and [

e Subscripts and superscripts for limits and sums (but not integrals) are writ-
ten under rather than next to the symbols

e Text is centered

Other than these differences, though, displayed expressions and inline expressions
are very similar.

One final note about the way displayed formulas are typeset: Be careful about
whether you’re putting your equation into a new paragraph or not. If your formula
is in the middle of a sentence or paragraph, then don’t press Return. Doing so will
cause the text after the formula to start a new paragraph. That text will therefore
eventually be indented, depending on your document paragraph settings, which is
probably not what you want.

Exercise: Put the various equations in example_raw.lyx into display
mode, and see how they’re typeset differently.
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Exercise: Using various tools you’ve learned in this section, you should be
able to write an equation like':

logg x x>0

0 x=0
Y a+y/-1 x<0

4.5 More Math Stuff

fx) =

LyX’s math editor can do plenty more. By now, you’re familiar with the basics,
so we refer to the User’s Guide for tips on how to:

e Labeling and numbering expressions
e Multi-line equations
e Change typefaces, e.g., to write bold-face text in an expression.

e Fine-tune font sizes and spacing within an expression. (Don’t worry about
this until your final draft!)

e Write macros. These are very powerful, because you just define them once
at the top of the document, and then you can use them throughout the doc-
ument.

e Do lots of other things that can’t be mentioned in this Tutorial.

! After you’ve done it the hard way, give Insert>Math > Cases Environment a try.
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Chapter 5

Miscellaneous

5.1 Other major LyX Features

We haven’t gone through all the possible commands in LyX, and we aren’t plan-
ning on it. As usual, see the User’s Guide and the Embedded Objects manual for
more information. We’ll just mention a couple more major things LyX can do:

e LyX has WYSIWYM support for tables. Use the Insert>Table (toolbar

button ﬁv) to get a table. Click on the table with the right button to get a
Table Settings dialog box which allows extensive table editing.

e LyX also supports including pictures in any format within documents. (You

guessed it: Insert> Graphics (toolbar button ). Then browse for the fig-
ure file, rotate or scale it, etc.) Tables and figures can have captions, and
LyX will automatically generate lists of figures and/or tables.

e LyX is heavily configurable. Everything from how the LyX window looks
to how the output comes out can be configured in a number of ways. Much
configuration is done through Tools > Preferences. For more information
on this, check out Help > Customization.

e LyXis being developed by a team of programmers on five continents. There-
fore, LyX has better support for non-English languages (such as Dutch, Ger-
man, French, Greek, Czech, Turkish, ...) than many word processors. Even
the right-to-left languages Arabic, Farsi, and Hebrew and the Asian lan-
guages Chinese Japanese, and Korean are supported. You can write docu-

27
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ments in other languages and you can also configure LyX to show its menus
and error messages in other languages.

e The LyX menus feature keybindings. This means that you can do Filer
Open by pressing M-F followed by O or by using the binding which is
shown next to it in the menu (C-O by default). Keybindings are also config-
urable. For information on this, check out Help > Customization.

e LyX can read IAIEX documents. See section 5.2.2.
e Spellchecking, thesaurus, and word count facilities are available.

e Generation of indexes and nomenclatures/glossaries is supported.

5.2 LyX for IXTEX Users

If you don’t know anything about I&TEX, you don’t have to read this section. Ac-
tually, you might want to learn about I£TEX, and then read this chapter. However,
some who begin to use LyX will be familiar with I&TEX. If you are such a person,
you may be wondering if LyX can really do everything I&IEX can do. The short
answer is that LyX can do pretty much everything I&IgX can do in one form or
another, and it definitely simplifies most parts of writing a I£I[EX document.

Because this is just a tutorial, we are only going to mention things that new
LyX users will most likely be interested in. In the interests of keeping the Tutorial
short, we will give only minimal information here. The the Extended Features
and the Embedded Objects manual have a great deal of information on differences
between LyX and ISTEX, and how to do various I&TEX tricks in LyX.

5.2.1 TgX Mode

Anything that you enter in TgX mode will be passed straight to I&TEX, and will be
displayed in red on the screen. You can use TgX commands in LyX by choosing

Insert> TeX Code (toolbar button TEx). This creates a box where everything within
it is passed straight to IATEX.

In a math formula, TgX mode is handled a bit differently. TgX mode is there
entered by typing a backslash. The backslash is not written out, but anything
you type afterwards will be in red. You exit TgX mode by typing Space or some
other non-alphabetic character, like a number, underscore, caret, or parenthesis.
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Once you exit TgX mode, if LyX knows the TEX command you’ve typed in, it
will convert it to WYSIWYM. So if you type “\gamma” in a formula and then
press Space, LyX will change the red “gamma” to a blue “y”. This will work
for almost all, non-complicated math macros. This may be faster than using the
Math Toolbar, and will be especially convenient for experienced IXTEX users.

As a special case, if you type a brace in TgX mode, then the beginning and
ending braces will be inserted in red, then take you out of TgX mode and place the
cursor between the braces. This makes it more convenient to type commands that
LyX doesn’t know which take an argument.

LyX can’t do absolutely everything that ISIEX can do. Some fancy functions
are not supported at all, while some work but aren’t WYSIWYM. TgX mode al-
lows users to get the full flexibility of I&TEX, while having all the convenient fea-
tures of LyX, like WY SIWYM math, tables, and editing. LyX could never support
every IXIEX package. However, by typing \usepackage {foo} in the pream-
ble (see section 5.2.4.2), you can use any package you want — although you won’t
have WYSIWYM support for that package’s features.

5.2.2 Importing IATEX Documents — tex21lyx

You can import a ISTEX file into LyX by using the File > Import> IATEX (plain) menu
in LyX. This will call the program tex21yx which will create a file foo.lyx
from the file foo . tex and then open that file. If the translation doesn’t work, you
can try calling tex21yx from the command line, possibly using fancier options.

tex21lyx will translate most legal I&TEX, but not everything. It will leave
things it doesn’t understand in TgX mode, so after translating a file with tex21yx,
you can look for red text and hand-edit it to look right.

tex21lyx has its own manpage. Read it to find out about which IXTEX com-
mands and environments aren’t supported, bugs (and how to get around them),
and how to use the various options.

5.2.3 Converting LyX Documents to IXTEX

You might wish to convert a LyX Document to a I&TEX file. For example, a co-
worker or co-author who doesn’t have LyX might want to read it. Select File >
Export> IATEX. This will create a file whatever. tex fromthe whatever. lyx
file you are editing. LyX always creates temporary I&IgX files when viewing or
printing files.
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5.2.4 IATEX Preamble
5.2.4.1 Document Class

The Document > Settings dialog takes care of many of the options that you would
input in a \documentclass command. Change the class, default font size and
paper size here. Put any extra options to the \document class command in the
Extra Options area.

5.2.4.2 Other Preamble Matter

If you have special commands to put in the preamble of a IATEX file, you can use
them in a LyX document as well. Select Document > Settings > IATEX Preamble
and type in the dialog window (or from the document settings dialog, depending
on the frontend). Anything you type will (like with TgX mode) be sent directly to

IATEX.

5.2.5 BibTEX

LyX has support for BibTgX, which allows you to build databases of bibliograph-
ical references to be used in multiple documents. Select Insert>List / TOC>
BibTeX Bibliography to include a BibTeX file. In the Database field you load
BibTgX files, in the Style field you can load BibTEX style files.

After you’ve done this, you can use citations from any bibliographies you’re
including with Insertr> Citation (see section 3.6). LyX will take care of running
BibTEX. The box in the Citation dialog will show a list of all the references in
your BibTeX file.

5.3 Errors!

Sometimes when you IKIEX a document, there will be errors, things that LyX
or ISTEX can’t understand. When this happens, LyX will open a IATEX Errors
dialog. Clicking on individual errors in this dialog will take you to the place in the
LyX document where the error occurs and also display the detailed IXTEX error
message.
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